Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Custom Tag Error: Directive: Invalid attribute, prefix  RSS feed

 
David Wei
Greenhorn
Posts: 17
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I am trying to create a custom tag to be used in a web application using VAJ 3.5.3. I got the error I do not understand as follows:
JSP Syntax Error: "Directive: Invalid attribute, prefix
it seems it complains the code
<%@ taglib uri="cpp_tags_1_0.tld" prefix="CPP" %>
in jsp page.
can you tell me why? Thanks,

David
 
Simon Brown
sharp shooter, and author
Ranch Hand
Posts: 1913
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That doesn't sound good. You could try swapping the order of the attributes around although this probably won't change anything!
Have you done a search of the IBM/Websphere forum?
Simon
 
Marty Hall
Author
Ranch Hand
Posts: 111
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

it seems it complains the code
<%@ taglib uri="cpp_tags_1_0.tld" prefix="CPP" %>
in jsp page.

This is the correct syntax for . So, we need more information:
  • The full error message from the server
  • The full JSP page (boil it down to the simplest

  • example that illustrates the problem)
  • The TLD file (again, use the simplest possible one)


  • For more on building custom tags, please see Chapter 14 of http://pdf.coreservlets.com/.
    Cheers-
    - Marty
     
    Manjunath Subramanian
    Ranch Hand
    Posts: 236
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Take a look @ http://www.coderanch.com/t/70510/Websphere/JSP-custom-tag-withVAJ
    This should solve your problem.
    Manjunath
     
    Consider Paul's rocket mass heater.
    • Post Reply Bookmark Topic Watch Topic
    • New Topic
    Boost this thread!