This week's giveaway is in the Threads forum.
We're giving away four copies of Java Concurrency Live Lessons and have Doug Schmidt on-line!
See this thread for details.
Win a copy of Java Concurrency Live Lessons this week in the Threads forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Warning: Page has expired  RSS feed

 
Pat De Luis
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,
I'm completely new to all of this, I'm getting screen error Warning: Page has expired after a short period of time. I check values in the sessionTimeoutMillis
an d looks ok, this only happens for the screen developed using JSP but not for previous ones
Any idea/s?
Thanks a lot
 
Simon Brown
sharp shooter, and author
Ranch Hand
Posts: 1913
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is this when you are clicking "back" in your browser or something? Do you have any caching options/headers set in your pages?
Simon
p.s. "irespond", thanks for joining JavaRanch, but could you just take a quick look at the naming policy and edit your profile.
 
Pat De Luis
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Simon,
As suggested I change my user name (Thanks ) About the warning message, it happens when I leave the screen without any interaction for more than 20 minutes (aprox) and then I try to do something. I have sessionTimeoutMillis parameter set to 28800000 and The "Session Timeout" option under Web Descriptor / Web App Descriptor / session Config. is set to -2
Thanks
 
sampy jagan
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What is the WebServer you are using?
If it is Tomcat you can try increasing the checkInterval attribute. It specifies how often to check for expired sessions, default is 60 Seconds.
Ex:
<SessionExpirer checkInterval="120" />
Regards
jagan
 
sampy jagan
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The above change you have to make in Server.xml
Regards
jagan
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!