• Post Reply Bookmark Topic Watch Topic
  • New Topic

JSP not working  RSS feed

 
Ray Tam
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have installed Tomcat 4.1.18 successfully on Windows XP Pro. I run the startup.bat in my apache\bin directory and when I key in http://localhost:8080, I get the start page. However, when I try to bring up my JSP page, it is not working.
<html>
<body>
<% out.println ("testing JSP"); %>
<h1>JSP test</h1><br><hr>
</body>
</html>
Any idea why this is not working? I see the "JSP test" fine, however the "testing JSP" doesn't show up which means the URL is valid. I have intentionally made typos in the out.println and it has been ignored. Thanks in advance.
 
Irene Loos
Ranch Hand
Posts: 78
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ray,
How do you determine that your JSP page is not working? If you see "JSP Test" from your jsp page that means it is working at least partially up to this line.
 
Ray Tam
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Irene,
I would expect the HTML page to display "testing JSP" followed by "JSP test". I am only seeing the latter which is in HTML, but the output from the scriptlet is nowhere to be seen. Thanks.
 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13078
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can you get the JSP examples that come with Tomcat working?
Bill
 
Ray Tam
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
numguess.jsp is working.
 
Ray Tam
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I found my problem - I must not have set the classpath correctly. Thanks for everybody's help.
 
Consider Paul's rocket mass heater.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!