Win a copy of The Way of the Web Tester: A Beginner's Guide to Automating Tests this week in the Testing forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

jstl tomcat issue

Pat Parvathaneni
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am having a problem running few of the JSTL
(Expression Language) tags in Tomcat 5.0 pre-release
version. I tried the same code even in 4.1.12 version
as well, the problem still persists.

I have created a directory called myapps under the
webapps directory in Tomcat(4.1.12). Within myapps are
two folders: jsp and WEB-INF. In jsp I have placed
the requisite jsp/HTML pages. In WEB-INF I placed all
the required TLD's and created a folder called lib to
house all the jar files. My JSLT is version
1.0.3, which I downloaded as
When I start my non-JSTL-based jsp it works fine so I
know my directory structure is correct.
The output for the following code is also listed
<%@ taglib prefix="c"
uri="" %>
<title>Take The Pizza</title>
<table border="1">
<c ut value="Hello ${} "/>

When I try to run my JSTL-based jsp I get the
following output:
Name: Hello J2EErocks ${}
Here <c ut seem to work fine , but ${} is
treated as text.
I have also tried putting the tld files into the
WEB-INF directory and linking
to them by using the web.xml file:
but still get the same error.
Sure appreciate some advice .
Thanks very much,
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic