• Post Reply Bookmark Topic Watch Topic
  • New Topic

what error would be this?

 
vikram nalagampalli
Ranch Hand
Posts: 91
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,
I am trying to execute a JSP file by name testHarness.jsp using weblogic and i am getting the following error. I would really appreciate if some one could tell me why i am encountering this problem.
Compilation of 'C:\dev\wsg\proj\GMHN\GMHN\presentation\test\target\weblogic70\testserver\.wlnotdelete\_appsdir_claimsweb_dir_claimsweb_4859759\jsp_servlet\_jsp\__testharness.java' failed:
--------------------------------------------------------------------------------
(Failed to parse compiler output. See full output below).
--------------------------------------------------------------------------------
Full compiler error(s):
java.io.IOException: CreateProcess: javac -classpath C:\dev\wsg\proj\GMHN\GMHN\presentation\test\target\weblogic70\applications\claimsweb\WEB-INF\classes;C:\dev\wsg\proj\GMHN\GMHN\presentation\test\target\weblogic70\.\testserver\.wlnotdelete\_appsdir_claimsweb_dir_claimsweb_4859759\jarfiles\WEB-INF\lib\acs-util5813.jar;C:\dev\wsg\proj\GMHN\GMHN\presentation\test\target\weblogic70\.\testserver\.wlnotdelete\_appsdir_claimsweb_dir_claimsweb_4859759\jarfiles\WEB-INF\lib\aspectjrt5814.jar;C:\dev\wsg\proj\GMHN\GMHN\presentation\test\target\weblogic70\.\ testserver\.wlnotdelete\_appsdir_claimsweb_dir_claimsweb_4859759\jarfiles\WEB-INF\lib\axis5815.jar;C:\dev\wsg\proj\GMHN\GMHN\presentation\test\target\weblogic70\.\testserver\.wlnotdelete\_appsdir_claimsweb_dir_claimsweb_4859759\jarfiles\WEB-INF\lib\cactus-ant5816.jar;C:\dev\wsg\proj\GMHN\GMHN\presentation\test\target\weblogic70\.\testserver\.wlnotdelete\_appsdir_claimsweb_dir_claimsweb_4859759\jarfiles\WEB-INF\lib\caD
at java.lang.Win32Process.create(Native Method)
at java.lang.Win32Process.<init>(Win32Process.java:66)
at java.lang.Runtime.execInternal(Native Method)
at java.lang.Runtime.exec(Runtime.java:551)
at java.lang.Runtime.exec(Runtime.java:477)
at java.lang.Runtime.exec(Runtime.java:443)
at weblogic.utils.Executable.exec(Executable.java:208)
at weblogic.utils.Executable.exec(Executable.java:133)
at weblogic.utils.compiler.CompilerInvoker.compileMaybeExit(CompilerInvoker.java:545)
at weblogic.utils.compiler.CompilerInvoker.compile(CompilerInvoker.java:354)
at weblogic.servlet.jsp.JspStub.compilePage(JspStub.java:406)
at weblogic.servlet.jsp.JspStub.prepareServlet(JspStub.java:206)
at weblogic.servlet.jsp.JspStub.prepareServlet(JspStub.java:160)
at weblogic.servlet.internal.ServletStubImpl.getServlet(ServletStubImpl.java:447)
at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:287)
at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:242)
at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:5363)
at weblogic.security.service.SecurityServiceManager.runAs(SecurityServiceManager.java:721)
at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:3043)
at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2466)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:152)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:133)
 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13078
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It looks like your environment is not set up right to compile JSP. Are you able to run the JSP examples that weblogic provides?
Incidently, posting the same question to multiple forums is not a good idea - the people who are likely to answer your questions read both the JSP and servlet forums so having the same question in two places just makes it harder.
Bill
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!