Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Null value when submit TextArea to JSP

 
Emil Karlsson
Ranch Hand
Posts: 63
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
when I try to submit my form in html everything works perfect, except the textarea. the request.getParameter("<name-of-textarea>") will only give me a null value.
Anyone who seen this?

/Emil
[ July 10, 2003: Message edited by: Emil Karlsson ]
 
Manish Sharma
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi
Check the name of textarea which you are passing in getParameter method. it should be same which you used in html form
Manish Sharma

Originally posted by Emil Karlsson:
Hi,
when I try to submit my form in html everything works perfect, except the textarea. the request.getParameter("<name-of-textarea>") will only give me a null value.
Anyone who seen this?

/Emil
[ July 10, 2003: Message edited by: Emil Karlsson ]
 
Emil Karlsson
Ranch Hand
Posts: 63
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks
But that was the first thing I checked and the name was the same!
Do you have any other suggestion?
When I change to a textbox instead of the textarea it works fine!

/Emil
[ July 10, 2003: Message edited by: Emil Karlsson ]
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 64971
86
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Emil,
At this point you're going to have to show us some code.
I'd also suggest doing so in the HTML/Javascript forum since this isn't really JSP-related.
hth,
bear
 
Rubal Sidhu
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Check if your TextArea is in <form> tag else send me the code.
njoi
 
Anonymous
Ranch Hand
Posts: 18944
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
A very common error is to write : <input type='textarea'> , rather than <textarea>data</textarea>. Check for this.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic