• Post Reply Bookmark Topic Watch Topic
  • New Topic

NIO and JDK version

 
John Davis
Ranch Hand
Posts: 189
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I would like to use java.nio in order to sidestep the prehistoric char [] declarations needed to implement IO functionality in JSP scriptlets. However, my operations people have us at JDK 1.3.1_02 and have no plans to upgrade to JDK 1.4. Is it both possible and advisable to download the java.nio package for use in this application server which uses JDK 1.3.1?
 
amol re
Ranch Hand
Posts: 36
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is there a separate just java.nio download available??
I wouldnt take the risk because maybe some classes in java.nio are dependent on some jdk1.4 implementation of some other J2SE package.
...Unless Sun promises that its safe to download and use it with jdk1.3...
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!