Win a copy of Kotlin in Action this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

JSP debugging with Eclipse (Tomcat 4.0.3, Eclipse 2.1.1) - Works to a point but canno  RSS feed

 
John Cogan
Ranch Hand
Posts: 32
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I think I have set-up everything correctly including the work directory and the package org.apache.jsp
When I set a breakpoint in the servlet representation (faq$jsp.java) of the jsp (faq.jsp), the debugger successfully stops at that breakpoint. However, when I try to "Step Over", it tries to open faq$jsp.class and gives the error in the editor Source not found - There is no source file attached to the class file faq$jsp.class.
This is despite faq$jsp.class and faq$jsp.jsp being in the same directory ie work\org\apache\jsp\jsp
I would be very grateful if you had any ideas on what might be happening here.
Best regards,
John
 
R K Singh
Ranch Hand
Posts: 5390
1
Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
try by copying saq$jsp.java in the same folder where your jsp is ??
Cant you put break points in JSP ?? I think there has to be some plug-in for debugging of JSP in eclipse.
try and tell
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 66205
151
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Moving to the IDEs and other tools.
bear
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!