• Post Reply Bookmark Topic Watch Topic
  • New Topic

is this special char "� " a bug?  RSS feed

 
Rajapragada Dharani
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
As this is my first post to this forum kindly forgive any formatting mistakes.When I was writing my jsp code and running it using jakarta-tomcat-3.2.1 very surprisingly get to see in my browser this special charecter "�" between two tables of my jsp.Where that obviously is never writtem in the jsp.I tried several ways but the bug persists to sit there.
Can any one kindly help me with this stuff......this may look very funny but the page is very important for me as i have to upload it to the server as sson as possible.I even tried rebuilding my jsp but of no use.
========================JSP CODE=========================
body
html:form action="/jsp/HRM/EditProfile.do"
----then some java code-----
String val = request.getParameter("val");
request.setAttribute("val",val);
String webroot = "";
webroot = HtmlUtil.getWebRoot(request);
User userSessionObject = (User) request.getSession().getAttribute("CAPTURE_SESSION_USER");
String userId = userSessionObject.getUserId();
----------------------------
jsp:include page="myprofileTabs.jsp" flush="true"/
table class="topborderless"
tr
td class="imageNoRepeat" colspan="4"bean:message key="prompt.EditProfile"//td
/tr
/table // this is the place where i get this "�"
table
---------some more java code----
ArrayList selectedListRecords = (ArrayList)request.getAttribute("selectedListRecords");
int selectedListRecordsSize = selectedListRecords.size();
if (selectedListRecordsSize0)
{
String[] strCurrValues = (String[])selectedListRecords.get(0);
ArrayList userPhoto = null;
String strPhoto[] = new String[3];
for(int i=0;i3;i++)
strPhoto[i] = "";
userPhoto = (ArrayList)request.getAttribute("userPhoto");
if(userPhoto!=null && userPhoto.size()0)
{
strPhoto = (String[])userPhoto.get(0);
}
session.setAttribute("ftype","Image");
-----------------------------------------------
tr
td width="100%" align="center" class="buttonBarLeft" colspan="5"
html:button styleClass="submitbuttons" property="AB" onklick="return validate('Edit Profile')"bean:message key="button.UpdateProfile"//html:button
html:button styleClass="submitbuttons" property="AB" onklick="javascript:gotoAddMoreDetails('%=userSessionObj.getUserId()%')"bean:message key="button.AddMoreDetails"//html:button
/td
/tr
tr //............................my code follows this way.
================== ===============================
 
Eric Pascarello
author
Rancher
Posts: 15385
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Goto your view source on the HTML page. Look to see where that character is. It does not have to be between the tables, it could in inserted in a wrong place in the table above it or below it.
Eric
 
Rajapragada Dharani
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
HI,
Thanks Eric Pascarello i got the solution.Actually the problem was with the include page between tables.The special charecter is nowhere but it appears as the include page is written in a form which is closed twice, once in that page and once in the calling page.I removed the /form tag from included page and the character dissapered.Any ways I'am very thankful for your immediate reply.
cheeres n regards Rajapragada.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!