• Post Reply Bookmark Topic Watch Topic
  • New Topic

Unable to compile class for JSP  RSS feed

 
Bruce Jin
Ranch Hand
Posts: 672
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I use Eclipse and Tomcat 4.1.12.
I just switched from Eclipse 2.1 to 3.0M7. Now when I run a jsp I get this error:
org.apache.jasper.JasperException: Unable to compile class for JSP
An error occurred at line: -1 in the jsp file: null
Generated servlet error: [javac] Compiling 1 source file
org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:120) at org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:293)
Any ideas? Thanks.
 
Nicholas Cheung
Ranch Hand
Posts: 4982
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Bruce,
Are you sure the existing jar files in the classpath of the new version of Eclipse are correct? You may use NEW jar file (come with the new version of Eclipse), but your code using the older version.
That's why the jar files are not compatable with your current code.
Did you check that?
Nick.
[ March 02, 2004: Message edited by: Nicholas Cheung ]
 
Nicholas Cheung
Ranch Hand
Posts: 4982
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Bruce,
In addition, please also check the order to the classpath.
If the newer version (unsuitable one) is in front of the older version in the classpath, it may also cause problems.
Check everything in the classpath, as well as the version, and the project's dependent lib.
Hope this help.
Nick.
 
Bruce Jin
Ranch Hand
Posts: 672
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Nick.
I checked. No luck.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!