• Post Reply Bookmark Topic Watch Topic
  • New Topic

EL configuration is not working

 
Hussein Baghdadi
clojure forum advocate
Bartender
Posts: 3479
Clojure Mac Objective C
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi.
I put the following element in my web.xml file in order to enable the EL in my all JSP pages.

well, it doesn't work, I also tried to remove <jsp-cofig> element and use <jsp-property-group> , but the same result.
any ideas ??
thanks.
[ January 20, 2005: Message edited by: Bear Bibeault ]
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 65524
105
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It should not be necessary to put any of this type of goo into your web.xml.

First things first: what container? Tomcat 5?

Second thing: is your web app declared using the Servlet 2.4 XML schema in your web.xml?
 
Hussein Baghdadi
clojure forum advocate
Bartender
Posts: 3479
Clojure Mac Objective C
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm using Tomcat 5.0.28 and the schema declaration is :
<web-app xmlns="http://java.sun.com/xml/ns/j2ee"
xmlns:xsi="http://www.w3c.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee
http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd" version="2.4">
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 65524
105
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hmm, that should be enough to enable the EL. How do you know it's not working?

I recommend coding up a super simple JSP page with just something like:

<div>3 + 4 = ${3 + 4}</div>

as the body and see what that gives you.

Another dumb question: are you sure that the JSP is in the same web app as your web.xml? Some people seem to be having trouble keeping web apps straight in the Tomcat webapps structure.
 
Hussein Baghdadi
clojure forum advocate
Bartender
Posts: 3479
Clojure Mac Objective C
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
the only way to get EL working is using isELIgnored attribute.
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 65524
105
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Does it work for you when you set that?

I've never set it and I've never had a problem. Odd.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!