Win a copy of Java EE 8 High Performance this week in the Java/Jakarta EE forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Beginning J2EE. Cannot reach deployed EAR.  RSS feed

Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hey there all,

First off, I'm using default settings for all ports on the J2EE reference implementation.

I'm just starting out with J2EE 1.4 and have been following along with the book "Beginning J2EE 1.4: From Novice to Professional". I have successfully deployed and run my first JSP page as a Web Archive (WAR) which I can happily access using



My problems start when trying to deploy my first Enterprise Archive (EAR) application. I've gone through the instructions a couple of times and the thing seems to deploy correctly, but no joy accessing it.

Here is my file structure....


In the deploy tool, I've set up the web context to "Ch03" as instructed and verified everything so that there are no syntax errors or anything like that.
According to the deploy tool, my server is apparently running on localhost:4848 and under deployed applications the application is called JavaFAQ and has a status of "Running".
The book says that I should access it by going to the URL


but this doesn't work, even though I've set the web context in the deploy tool to welcome.jsp. So, I checked the Admin console where I have the following: -

Host Name: localhost
HTTP Port(s): 8080, 8181, 4848
IIOP Port(s): 3700, 3820, 3920
Configuration Directory: C:/j2eesdk1.4/AppServer/domains/domain1\config
Installed Version: Sun Java System Application Server Platform Edition 8.1 (build b42-fcs)
Debug: Not Enabled

So I figured the port was wrong in the book or something so tried


but still no luck.....I get a 404 from the J2EE server saying "The requested resource (/Ch03) is not available."

What can can I check? Any advice? As I said, the deploy tool says it deployed and running. I just can't seem to get to it!

Also tried http://localhost:4848/JavaFAQ/Ch03 with no joy. I've had another look in the Admin console, that the app is listed under Enterprise Applications rather than EJB modules, if that makes any difference.
Author and ninkuma
Posts: 66425
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Moved to the EJB/J2EE forum.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!