• Post Reply Bookmark Topic Watch Topic
  • New Topic

actual file content is showing[browser issue]  RSS feed

 
Bhavin Sanghani
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When I click on link of my application (.do extension- using Struts/JSP)..it shows me the actual content of the file instead of showing GUI....

I'm using IE 6 SP2, on Windows XP. With Mozila this is not an issue.
This problem is not with each and every link...I'm not able to understand where is the problem?

Another thing, how we can make sure that our application will work with all browsers? Is there any standard mechanism?

-Bhavin Sanghani
 
Bhavin Sanghani
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
<!-- $Header: ....... $ -->

if above is first line in my JSP file it shows me actual content otherwise it works fine...what could be the issue ? any idea?

-bhavin
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Look at the output (view source from your browser) and compare the two.
Is <!-- $Header: ....... $ --> being substituted with something else when your JSP runs?


As far as making sure your code works in all browsers.
Stick with the W3C specs and test your code in all the browsers that you want to support as you write it.
This is an ongoing battle that all web developers have to deal with.
There is no one answer.
XHTML looks like it might bring us a lot closer.
 
Bhavin Sanghani
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No its same...whatever I'm able to see in View Source...same is displayed in Browser Window...

Is there any configuration in browser to supress HTML comment?

-bhavin
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try manually setting the content type at the top of the page;
<%request.setContentType("text/html");%>

What application server are you using anyway?
 
Bhavin Sanghani
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I can not change the code...as its working fine with other IE versions on diff machines. I'm using Weblogic Server on local machine.

-bhavin
 
Bhavin Sanghani
Ranch Hand
Posts: 67
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Okey..but this is not AppServer issue because any other JSP page starts with HTML comment on Internet gives me same result!

-Bhavin
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you can not change the code, then you're asking in the wrong forum.
It sounds like this isn't a JSP issue anyway.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!