• Post Reply Bookmark Topic Watch Topic
  • New Topic

Quick custom tag problem  RSS feed

 
Jon Brasted
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi.

I have made a custom tag with the view of using it as a 'method', i.e. declaring the code for the method and calling it within a JSP page using the custom tag.

The problem I have is that the rest of the body of the page is not evaluated after the tag, even though I specify the return value EVAL_BODY for doEnd().

Would anyone be able to kindly have a quick look at the code?

Thanks.
Jon



 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 66153
146
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you sure that your tag code is not throwing an exception that is causing the remainder of the page to not execute?
 
Jon Brasted
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
How would I know? I thought I dealt with the two main exceptions? (Jsp and IO)
 
ramprasad madathil
Ranch Hand
Posts: 489
Eclipse IDE Java Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Was interested enough to find out if using java 5.0 somehow screwed it up (though all logic said no ), that I tried out your code and needless to say it works fine for me.

The problem is not in your tag (maybe in the --some other stuff-- that you have posted.

cheers,
ram.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!