Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

frustrated w/ JSTL  RSS feed

 
Vinnie Jenks
Ranch Hand
Posts: 207
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am simply trying to get JSTL to work in my web app and I've had zero success googling & tweaking for the last 2 hours...I'm in need of some serious, *SIMPLE* explanations.

The last thing I tried was creating a netbeans web app which handles all of the JSTL jar dependencies automatically. The problem is; 1) I want to know how to do this w/o an IDE and 2) I use eclipse and WTP for my development and there should be a simple way of doing it, but I haven't figured it out.

So, after creating the netbeans project I found the two libraries used for jstl, which are:

standard.jar
jstl.jar

In eclispe I copied those two libs to my webapp's lib folder and put them in tomcat's common/lib folder. In eclipse I added the jars to my project's java build path->Libraries screen.

I assumed this would take care of business but now I get this error:

org.apache.jasper.JasperException: Unable to read TLD "META-INF/c.tld" from JAR file "file:/C:/Documents and Settings/me/My Documents/Projects/Portlets/.deployables/Portlets/WEB-INF/lib/standard.jar": org.apache.jasper.JasperException: Failed to load or instantiate TagLibraryValidator class: org.apache.taglibs.standard.tlv.JstlCoreTLV

Any ideas? What's the easy way?

Thanks!

-v
 
Ilja Preuss
author
Sheriff
Posts: 14112
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Moving to our JSP forum...
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 65826
134
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Some context might help. At minimum:

  • Where did you get your JSTL implementation?
  • What version of the JSTL did you download? 1.0 or 1.1?
  • What version of Tomcat?
  • What URI are you using on the JSPs for the core library?


  • [ August 25, 2005: Message edited by: Bear Bibeault ]
     
    Vinnie Jenks
    Ranch Hand
    Posts: 207
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Originally posted by Bear Bibeault:
    Some context might help. At minimum:

  • Where did you get your JSTL implementation?
  • What version of the JSTL did you download? 1.0 or 1.1?
  • What version of Tomcat?
  • What URI are you using on the JSPs for the core library?


  • [ August 25, 2005: Message edited by: Bear Bibeault ]


  • I have netbeans 4.1 installed so I nabbed the standard.jar and jstl.jar that comes w/ it, which I believe is JSTL 1.1
  • Tomcat 5.5.9
  • http://java.sun.com/jsp/jstl/core

  •  
    Bear Bibeault
    Author and ninkuma
    Marshal
    Posts: 65826
    134
    IntelliJ IDE Java jQuery Mac Mac OS X
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    which I believe is JSTL 1.1


    Might be a good idea to find out for sure.

    You stated that you placed the jars in Tomcat's common/lib, yet the container seems to be looking elswhere:

    org.apache.jasper.JasperException: Unable to read TLD "META-INF/c.tld" from JAR file "file:/C:/Documents and Settings/me/My Documents/Projects/Portlets/.deployables/Portlets/WEB-INF/lib/standard.jar":

    Can you explain how you set things up to cause this?
    [ August 25, 2005: Message edited by: Bear Bibeault ]
     
    Vinnie Jenks
    Ranch Hand
    Posts: 207
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    I put them in the common lib folder in tomcat out of sheer persistence because I haven't found anything else to work either. I've since removed them in order to prevent any conflict between the common libraries and what is in my WEB-INF/lib folder.

    After googling for a while I went here:

    http://jakarta.apache.org/site/downloads/downloads_taglibs-standard.cgi

    ...then I extracted the standard.jar and jstl.jar from the downloaded zip, placed them in my WEB-INF/lib folder...and it appears to be working.

    Obviously I was using the wrong version of JSTL for Tomcat 5.5.9.

    Thanks anyways!

    -v
     
    Gregg Bolinger
    Ranch Hand
    Posts: 15304
    6
    Chrome IntelliJ IDE Mac OS X
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    I modified out FAQ Entry on this topic to include links to the downloads for both versions.
    [ August 25, 2005: Message edited by: Gregg Bolinger ]
     
    • Post Reply Bookmark Topic Watch Topic
    • New Topic
    Boost this thread!