• Post Reply Bookmark Topic Watch Topic
  • New Topic

web.xml and Spring problem  RSS feed

 
cempaka melati
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am using weblogic 8.1 with SP4.

When I add the following to web.xml,

<?xml version="1.0" encoding="UTF-8"?>
<web-app xmlns="http://java.sun.com/xml/ns/j2ee"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd" version="2.4">

weblogic cannot be started correctly. The error is

Deployment descriptor "web.xml" is malformed. Check against the DTD: org.xml.sax.SAXParseException: cvc-elt.1: Cannot find the declaration of element 'web-app'.

When I try to deploy a Spring app where the xml says

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE beans PUBLIC "-//SPRING//DTD BEAN//EN"
"http://www.springframework.org/dtd/spring-beans.dtd">

Again I get errors on correct tag formats.

Help?
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 66207
151
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What version of the servlet specification does Weblogic 8.1 support?
 
cempaka melati
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
For the first error, I got help from bea forum. The answer was

The first error you showed is because you deployed a servlet 2.4 web.xml on WLS 8.1. WLS 9.0 is the first version to support that specification.

Still puzzled by my second error
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!