Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

JSP failing to compile on app server...  RSS feed

 
Bryce Martin
Ranch Hand
Posts: 269
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm trying to deploy a web app to our application server. One of my jsp's gives me a warning on my machine, but it still compiles and runs just fine. When I take it up to the production app server it blows up with the error..

JSPG0049E: /Recap.jsp failed to compile : /QIBM/UserData/WebSphere/AppServer/V6/Base/profiles/WAS60SVR/temp/CSAS400_WAS60SVR/WAS60SVR/RecapEAR/Recap.war/_Recap.java:40: unclosed character literal private final static char[] _jsp_string12 = "${status.index % 2 == 0 ? "'white'" : "'#EEE'" }; this.style.cursor='pointer'" onmooseout="this.style.background=".toCharArray();


This is the line of code(provided I can get this forum to post it) that it is blowing up on...

<td class="link" onmooseover="this.style.background='blue'; this.style.color=${status.index % 2 == 0 ? "'white'" : "'#EEE'" }; this.style.cursor='pointer'" onmooseout="this.style.background=${status.index % 2 == 0 ? "'white'" : "'#EEE'" }; this.style.color='blue'" onKlick="return LineDetail('Line.jsp?lnum=${rowL.line}&itm=${rowL.item}&div=${recapBean.division}&ord=${recapBean.order}', 'line${rowL.line}')">


I'm using Webpshere application server 6.0

Thanks for any input...
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 65825
134
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Your use of double quotes both as the delimiter for the attributes as well as internally to the attributes is boofing things up.
 
Bryce Martin
Ranch Hand
Posts: 269
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yeah, I pulled it out and instead just used $quot; character and that worked. I had the hardest time getting it to work before that dawned on me. I had other problems though. I had some jsps that I was no longer using that had errors in them. And that also made my precompile option fail.

All is well now.
Thanks
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!