This week's book giveaway is in the Jython/Python forum.
We're giving away four copies of Hands On Software Engineering with Python and have Brian Allbey on-line!
See this thread for details.
Win a copy of Hands On Software Engineering with Python this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Bear Bibeault
  • Knute Snortum
  • Liutauras Vilda
Sheriffs:
  • Tim Cooke
  • Devaka Cooray
  • Paul Clapham
Saloon Keepers:
  • Tim Moores
  • Frits Walraven
  • Ron McLeod
  • Ganesh Patekar
  • salvin francis
Bartenders:
  • Tim Holloway
  • Carey Brown
  • Stephan van Hulst

JSP deployment Error  RSS feed

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi everyone,
i need a serious help. i have been trying out this thing for a week and i still cant solve the issue.

I am using Netbeans 6 with bundled tomcat 6.0.14
OS: Windows Vista Home Premium 32 bit
Memory: 2 GB
Processor: AMD Turion 64 TL-58

i created a web application project using netbeans and tried to deploy it by running the project

and i saw following things in the console:

init:
deps-module-jar:
deps-ear-jar:
deps-jar:
Created dir: F:\test\build\web\WEB-INF\classes
Created dir: F:\test\build\web\META-INF
Copying 1 file to F:\test\build\web\META-INF
Copying 3 files to F:\test\build\web
library-inclusion-in-archive:
library-inclusion-in-manifest:
compile:
compile-jsps:
Starting Tomcat process...
Waiting for Tomcat...
Starting of Tomcat failed.
Deployment error:
Starting of Tomcat failed.
See the server log for details.
at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy

(Deployment.java:163)
at org.netbeans.modules.j2ee.ant.Deploy.execute(Deploy.java:104)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
at sun.reflect.GeneratedMethodAccessor97.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke

(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
at org.apache.tools.ant.Task.perform(Task.java:348)
at org.apache.tools.ant.Target.execute(Target.java:357)
at org.apache.tools.ant.Target.performTasks(Target.java:385)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
at org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:277)
at org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:460)
at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:151)
Caused by: org.netbeans.modules.j2ee.deployment.impl.ServerException: Starting of Tomcat

failed.
at org.netbeans.modules.j2ee.deployment.impl.ServerInstance._start

(ServerInstance.java:1270)
at org.netbeans.modules.j2ee.deployment.impl.ServerInstance.startTarget

(ServerInstance.java:1224)
at org.netbeans.modules.j2ee.deployment.impl.ServerInstance.startTarget

(ServerInstance.java:1035)
at org.netbeans.modules.j2ee.deployment.impl.ServerInstance.start

(ServerInstance.java:912)
at org.netbeans.modules.j2ee.deployment.impl.TargetServer.startTargets

(TargetServer.java:417)
at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy

(Deployment.java:140)
... 16 more
BUILD FAILED (total time: 3 minutes 3 seconds)







again i saw the tomcat console:


Using CATALINA_BASE: C:\Users\.netbeans\6.0\apache-tomcat-6.0.14_base
Using CATALINA_HOME: C:\Program Files\Apache Software Foundation\Apache Tomcat 6.0.14
Using CATALINA_TMPDIR: C:\Users\.netbeans\6.0\apache-tomcat-6.0.14_base\temp
Using JRE_HOME: C:\Program Files\Java\jdk1.6.0_03
Jan 6, 2008 4:55:55 PM org.apache.catalina.core.AprLifecycleListener init
Jan 6, 2008 4:55:55 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8084
Jan 6, 2008 4:55:55 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 1410 ms
Jan 6, 2008 4:55:55 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Jan 6, 2008 4:55:55 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.14
Jan 6, 2008 4:55:56 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8084
Jan 6, 2008 4:55:56 PM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Jan 6, 2008 4:55:57 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/63 config=null
Jan 6, 2008 4:55:57 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 1371 ms





I opened the browser and tried localhost:8084 and it shows tomcat startup page (tomcat has already started and its working). but why does netbeans 6 always report that tomcat failed to start.

please somebody help me. i am new to jsp and servlets and trying to study it. but since last week i could not make any progress. I am using netbeans 6 with bundled tomcat 6.0.14.

Thanks in advance.
[ January 06, 2008: Message edited by: Bear Bibeault ]
 
Marshal
Posts: 67192
169
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
"khaik khaik", please check your private messages.
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am also getting same error please help me in the same
 
roses are red, violets are blue. Some poems rhyme and some are a tiny ad:
RavenDB is an Open Source NoSQL Database that’s fully transactional (ACID) across your database
https://coderanch.com/t/704633/RavenDB-Open-Source-NoSQL-Database
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!