• Post Reply Bookmark Topic Watch Topic
  • New Topic

scripting-enabled doen not work

 
yogesh kalaskar
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I want to disable scriplets in all JSP. I am doing this by including <scipting-enabled> in web.xml as below, but its not working & scriplets still execute as without <scipting-enabled>.

I am using tomcat 6. Does anyone havean idea about it ??

<web-app>
-------
<jsp-config>
<jsp-property-group>
<url-pattern>*.jsp</url-pattern>
<scripting-invalid>true</scripting-invalid>
<el-ignored>false</el-ignored>
</jsp-property-group>
</jsp-config>
---
<web-app>
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE Ubuntu VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Your JSP need to be retranslated. Either modify the file and save it, or clear the container's cache.
 
yogesh kalaskar
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have modified the file & again built the war & then deployed but it doesn't work. And also i have restarted the tomcat server hoping to clear the cache but no luck.

Any other options???
 
Christophe Verré
Sheriff
Posts: 14691
16
Eclipse IDE Ubuntu VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Set the web-app tag correctly : see this
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by yogesh kalaskar:
... it doesn't work.


"it doesn't work" is one of the most useless statements we hear in these forums.

Always tell us exactly what happened, what error messages you saw, etc...
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!