Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

which lib file has javax.servlet.jsp.tagext.Tag?  RSS feed

 
Chandan Rajan
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am referencing javax.servlet.jsp.tagext.Tag from my code. I downloaded the Servlet development kit v2.1 from here:
http://java.sun.com/products/servlet/archive.html.

But unfortunately I do not find javax.servlet.jsp.tagext.Tag in it. If somebody could please indicate if I am downloading the right jar file? If I am not which library should I be looking for?

TIA,
Chandan
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 65826
134
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Chandan Rajan:
I downloaded the Servlet development kit v2.1 from here:
That's ancient and shouldn't be used.

Which container are you using? Tomcat 5? Tomcat 6? Other?
[ April 25, 2008: Message edited by: Bear Bibeault ]
 
Doug Slattery
Ranch Hand
Posts: 294
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you are using Tomcat, it's in ${TOMCAT_HOME}/lib/jsp-api.jar.

Aloha,
Doug

-- Nothing is impossible if I'mPossible
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 65826
134
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Doug Slattery:
If you are using Tomcat, it's in ${TOMCAT_HOME}/lib/jsp-api.jar.


For Tomcat 6, for Tomcat 5 it's: ${TOMCAT_HOME}/common/lib/jsp-api.jar

The servlet implementation is likewise in: ${TOMCAT_HOME}/common/lib/servlet-api.jar
[ April 25, 2008: Message edited by: Bear Bibeault ]
 
Chandan Rajan
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank for the help Doug Slattery and Bear Bibeault

I am using tomcat 5.5.

Linking to ${TOMCAT_HOME}/common/lib/jsp-api.jar helped.


Regards,
Chandan
 
Stevi Deter
Ranch Hand
Posts: 265
Hibernate Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Bear Bibeault:
That's ancient and shouldn't be used.


...unless you have a client that cannot/will not upgrade from Java 1.3 and Tomcat 3.2.4.

In which case, maybe you should still follow Bear's advice and refuse to even try. I'm still recovering from that trip through Old Skool Technology.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!