Win a copy of Kotlin in Action this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Backward compatibilty?  RSS feed

 
Rajkumar balakrishnan
Ranch Hand
Posts: 445
Android Eclipse IDE Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I used apache-tomcat-6.0.16 version previously and as far godaddy web hosting only support 5.0.27 version i just download the 5.0.27 version and run the project. But when i enter the user name and password it show me an error like this one in console
java.lang.ClassNotFoundException: com.mysql.jdbc.Driver

Whats wrong with that version?
Or do i miss anything?

Please let me know whats wrong.... :roll:
 
Martijn Verburg
author
Bartender
Posts: 3275
5
Eclipse IDE Java Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi there,

There are some significant differences with how resources such as JDBC drivers are treated between those versions of Tomcat, for example this page talks about changes between 5.0.x and 5.5.x, there will be similar documentation for the upgrade from 5.5.x to 6.0.x.

I assume you're stuck with that provider? It might be an idea to switch to a provider with a more up to date Tomcat instance (more secure for a start).
 
Rajkumar balakrishnan
Ranch Hand
Posts: 445
Android Eclipse IDE Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for your help...
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!