• Post Reply Bookmark Topic Watch Topic
  • New Topic

SOS - J2EE  RSS feed

 
eoctopus
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Today, I begin to use J2EE, I try to implement the follow command, but it doesn't work, please give me a hand.
1.j2ee -verbose
message is "Error:Set J2EE_HOME before running this script.
In fact, I already set the command "set J2EE_HOME = c:\j2ee"
2.deploytool
message is com/sun/enterprise/tools/deployment/main/Main couldn't found.
Please help
 
hanumanth reddy
Ranch Hand
Posts: 118
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
check have u run the program build script and include only the path with with out j2ee in J2EE_HOME
 
Ajith Kallambella
Sheriff
Posts: 5782
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
'eoctopus'
Welcome to JavaRanch!!
May I remind you that PROPER NAMES ARE NOW REQUIRED!! Please Read the JavaRanch naming policy for more details.
Javaranch appreciates your cooperation to comply with the official naming policy.
Ajith
 
mick Zhang
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi, all:
I have the same deploytool problem, and do not know how to do ,
"message is com/sun/enterprise/tools/deployment/main/Main couldn't found."
any help please.
Mick
Originally posted by eoctopus:
Today, I begin to use J2EE, I try to implement the follow command, but it doesn't work, please give me a hand.
1.j2ee -verbose
message is "Error:Set J2EE_HOME before running this script.
In fact, I already set the command "set J2EE_HOME = c:\j2ee"
2.deploytool
message is com/sun/enterprise/tools/deployment/main/Main couldn't found.
Please help

 
Madhu Juneja
Ranch Hand
Posts: 176
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You need to set the J2EE_HOME and JAVA_HOME. Note while setting with the 'set' DOS command, there should not be a space in-between '=' that is it should be set J2EE_HOME=c:\j2ee.
 
mick Zhang
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes, I have set that, but still can not run.
out of enviroment
Exception in thread "main" java.lnag.NoClassDefFoundError: com/sun/enterprise/tools/deployment/main/Main
after set to large memory, It run.
Thanks
Originally posted by Madhu Juneja:
You need to set the J2EE_HOME and JAVA_HOME. Note while setting with the 'set' DOS command, there should not be a space in-between '=' that is it should be set J2EE_HOME=c:\j2ee.

 
Prashant Jani
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
alternatively you can edit the '.bat' files to set the variables.
i guess this should solve your problems

 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!