• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

PB using Jenny with Oracle DB

 
Michael Dundi
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,
when I try to run Jenny on my Oracle DB, I get the following exception:
Exception in thread "main" java.lang.NoClassDefFoundError: java/sql/Savepoint
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:493)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:11
1)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:248)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:286)
at java.lang.ClassLoader.loadClass(ClassLoader.java:255)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:315)
at oracle.jdbc.driver.OracleDriver.getConnectionInstance(OracleDriver.ja
va:521)
at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:325)
at java.sql.DriverManager.getConnection(DriverManager.java:517)
at java.sql.DriverManager.getConnection(DriverManager.java:177)
at com.javaranch.db.Jenny.<init>(Jenny.java:333)
at com.javaranch.db.Jenny.main(Jenny.java:2085)
here is my .propertie file:
Driver=oracle.jdbc.driver.OracleDriver
URL=jdbc racle:thin:@**.***.***.*:1521:SMCPR //Not printed for security
UserName=*** //Not printed for security
Password=*** //Not printed for security
Destination=/Result/
Package=com.dundek
Facade=testFacade
MockDestination=/Result/Mock/
What am I missing out, please help!
Thanks in advance
Michael D.
 
Joel McNary
Bartender
Posts: 1840
Eclipse IDE Java Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello, Michael, and Welcome to JavaRanch!
What version of Java are you using? The java.sql.Savepoint class is a newer class (since v. 1.4), so if you are using any version of Java prior to that, you will not be able to use it.
 
Marilyn de Queiroz
Sheriff
Posts: 9067
12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Michael Dundi:
when I try to run Jenny on my Oracle DB, I get the following exception:
Exception in thread "main" java.lang.NoClassDefFoundError: java/sql/Savepoint
Michael D.

I'm glad you brought this up, Michael. We thought we had that problem fixed. Are you using the latest version of jr.jar? I'll check to be sure that it didn't accidentally get reverted back to the previous version.

As Joel stated, it is a difficulty brought about by the changes in the sdk from v1.3 to v1.4. I'll check it out again.
 
Michael Dundi
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Well, I am using Java 1.4.1_02 and 1.4.2. The pb occures with both versions. Well if you could let me know if you found anything on that bp, please let me know!
Thanks for your contribution to the Java comunity.
Michael D.
 
Michael Dundi
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I forgot, I just downloaded the latest version of Jenny to check if I had an outdated version, but no change in the exception I get!
Thanks
 
paul wheaton
Trailboss
Pie
Posts: 21890
Firefox Browser IntelliJ IDE Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sorry I'm late. I had some computer trouble.
Weird. Where does this savepoint stuff come from?

Hmmmm, It looks like SavePoint is part of the Java standard edition. Can you check to see if SavePoint.class is in your Java stuff?
 
Marilyn de Queiroz
Sheriff
Posts: 9067
12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Did you uninstall the 1.3 sdk before you installed the 1.4 sdk? I'm wondering if your registry may be pointing to the wrong sdk. You've probably already checked out your classpath.

We've used Jenny with both the 1.3 sdk and the 1.4 sdk with no problems since the patch was applied. But, as was noted above, the SavePoint stuff is only in v1.4 which makes me wonder about the sdk rather than about Jenny.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic