Last week, we had the author of TDD for a Shopping Website LiveProject. Friday at 11am Ranch time, Steven Solomon will be hosting a live TDD session just for us. See for the agenda and registration link
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • paul wheaton
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Carey Brown
  • Frits Walraven
Bartenders:
  • Piet Souris
  • Himai Minh

WebLogic 8.1 Connection Pools - # of Connections always 0

 
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello,

Just wondering if anyone could explain to me why after I set the initial number of connections for my Weblogic 8.1 connection pools to be 5, the monitor says there are 0 connections. I thought maybe it was because I was using Cloudscape, and the Cloudscape evaluation only allows 1 connection. However, I tried it with SQL Server, and I can connect, but the pool isn't opening 5 connections when I start the server.

Thanks,
Ryan
 
author & internet detective
Posts: 41086
848
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Ryan,
The connection pool opens connections as they are used. Once you start running the application with multiple users at the same time, the number of connections in the pool will increase. It doesn't happen when you just start the server.
 
Ryan P. Kane
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Thanks Jeanne,

My biggest problem was that I was using the default columns in the monitoring table. I added them all, and it made much more sense because it gave me the 'Curr Capacity' column, which made it clear that it was pooling. I was looking for that value in the 'Connections' column, but like you said, connections aren't shown there unless they are actual physical connections being used. Thanks again,

Ryan
 
You may have just won ten million dollars! Or, maybe a tiny ad.
free, earth-friendly heat - a kickstarter for putting coin in your pocket while saving the earth
https://coderanch.com/t/751654/free-earth-friendly-heat-kickstarter
reply
    Bookmark Topic Watch Topic
  • New Topic