This week's book giveaway is in the General Computing forum.
We're giving away four copies of Emmy in the Key of Code and have Aimee Lucido on-line!
See this thread for details.
Win a copy of Emmy in the Key of Code this week in the General Computing forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Junilu Lacar
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Knute Snortum
  • Devaka Cooray
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Ron McLeod
  • Carey Brown
Bartenders:
  • Paweł Baczyński
  • Piet Souris
  • Vijitha Kumara

java.sql.SQLException: Pls Help

 
Ranch Hand
Posts: 144
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

I have a java stored procedure called MailSend.java and using JDeveloper I deployed to Oracle 9i Database.

I am calling the stored procedure MailSend from a java class.However I am getting error :

java.sql.SQLException: ORA-06550: line 1, column 7:
PLS-00201: identifier 'MAILSEND' must be declared
ORA-06550: line 1, column 7:

Any help is highly appreciated

Thanks

Cosmos
 
author & internet detective
Posts: 39582
781
Eclipse IDE VI Editor Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Cosmos,
It looks like there is a compile/syntax error in the stored proc.
 
Ranch Hand
Posts: 1143
1
Eclipse IDE Oracle Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Cosmos,
Is this the first time you have tried creating a java stored procedure using JDeveloper? Did you deploy it using the JDeveloper wizards?

Personally, I don't like using the wizards because:
  • I don't know what the wizard is doing
  • I don't know what to do and where to start looking when something goes wrong



  • In any case, I'm guessing that "MAILSEND" is the name of your stored procedure, and if I remember correctly, the JDeveloper wizards always wrap stored procedures in packages (but I forget where the wizard gets the package name from). So you may simply need to prefix the invocation of MAILSEND with its package name. For example, if the package name is COSMOS, then the invocation needs to be:

    It may also be that you haven't (or should I say the JDeveloper wizards haven't) granted the required permissions to the MAILSEND procedure.

    Have you checked the data dictionary (of the Oracle database) to see whether MAILSEND exists, is valid, and has the correct permissions?

    Have you tried the JDeveloper forum (part of Oracle's OTN Web site?

    Good Luck,
    Avi.
     
    What a stench! Central nervous system shutting down. Save yourself tiny ad!
    Java file APIs (DOC, XLS, PDF, and many more)
    https://products.aspose.com/total/java
    • Post Reply Bookmark Topic Watch Topic
    • New Topic
    Boost this thread!