Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

ORA-04063?

 
Pat Peg
Ranch Hand
Posts: 195
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have a project (mostly jsp) which will do some database calls. When I drop the war file and run the app I get a HTTP 500 error with the following explanation
org.apache.jasper.JasperException: ORA-04063 : view "MyTable.db_Objects" has errors
I researched the 04063 error on the web and the only info I found suggested that the problem was in the database(shema changed) but when I pull my sql out of the code and run it in SQL Plus it seems to run fine.
Any ideas or suggestions?
[ March 16, 2005: Message edited by: Bear Bibeault ]
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 35279
384
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Pat,
Can you post some code for the error?
 
Pat Peg
Ranch Hand
Posts: 195
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm posting this in case someone elses runs into the problem. It turned out to be not in the code but in the database. Someone had deleted a table on which a view was based. Once the table was restored the code ran fine.

Moving on to other problems now
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 35279
384
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Pat,
Thanks for posting the solution!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic