• Post Reply Bookmark Topic Watch Topic
  • New Topic

ejb doubt

 
ravi ckumar
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hello,
Im trying to deploy 2 enterprise beans by using one ejb-jar & weblogic-ejb-jar files as follows
***********************************************************
< !DOCTYPE ejb-jar PUBLIC '-//Sun Microsystems, Inc.//DTD Enterprise JavaBeans 1.1//EN' 'http://java.sun.com/j2ee/dtds/ejb-jar_1_1.dtd'>
hellobean
hello.hHome
hello.hRemote
hello.beanImpl
Stateful
Container

balbean
bal.balHome
bal.balRemote
bal.balImpl
Stateful
Container
***********************************************************
so i will be using a single meta-if directory for both the beans, when im creating a jar file im using this same meta-inf dir only, it works fine till now , but when i do the ejbc xxx.jar -d c:\deploydir to get the stubs & skeletons im getting an exception
****************************************************
Loader.java:146)
at weblogic.ejb.deployment.dd.BeanDescriptor.loadClass(BeanDescriptor.ja
va:221)
at weblogic.ejb.deployment.dd.BeanDescriptor.getHomeInterfaceClass(BeanD
escriptor.java:446)
at weblogic.ejb.compliance.HomeClassChecker.(HomeClassChecker.java
:31)
at weblogic.ejb.compliance.SessionHomeClassChecker.(SessionHomeCla
ssChecker.java:25)
at weblogic.ejb.compliance.EJB11ComplianceChecker.getSessionCheckers(EJB
11ComplianceChecker.java:52)
at weblogic.ejb.compliance.EJB11ComplianceChecker.checkDeploymentUnit(EJ
B11ComplianceChecker.java, Compiled Code)
at weblogic.ejb.ejbc.EJBCompiler.complianceCheckJar(EJBCompiler.java:302
)
at weblogic.ejb.ejbc.EJBCompiler.checkCompliance(EJBCompiler.java:251)
at weblogic.ejb.ejbc.EJBCompiler.compileEJB(EJBCompiler.java, Compiled C
ode)
at weblogic.ejbc.runBody(ejbc.java, Compiled Code)
at weblogic.utils.compiler.Tool.run(Tool.java:80)
at weblogic.ejbc.main(ejbc.java:353)
Uncaught exception in class: weblogic/ejbc.main(String[]):
***********************************************************
im able to get the dir created but the stubs & skeletons are not created.........
what exactly is the problem here, i was able to deploy files individually till now, can any body pls help,
thanks
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!