Win a copy of Pro Spring MVC with WebFlux: Web Development in Spring Framework 5 and Spring Boot 2 this week in the Spring forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Jeanne Boyarsky
  • Liutauras Vilda
Sheriffs:
  • Rob Spoor
  • Bear Bibeault
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Piet Souris
Bartenders:
  • Frits Walraven
  • Himai Minh

resouce config problem

 
Ranch Hand
Posts: 55
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello,

I have two jdbc resources that I'm trying to run in a connection pool. The local on works and the second one doesn't. I don't know what the issue is... Can anyone spot anything?

In context.xml I have:


In webapp/ROOT/WEB-INF/web.xml I have:


I'm calling it thusly in my jsp file:


I'd been using beans to make my SQL connections and the reports server was successfully connecting with the following bean code:



When I execuite the page I get this error:

[ July 13, 2005: Message edited by: Bear Bibeault ]
 
Sheriff
Posts: 67537
173
Mac Mac OS X IntelliJ IDE jQuery TypeScript Java iOS
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Dude, were those the real usernames and passwords in your post? I blanked them out just in case!
 
Greenhorn
Posts: 27
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
You haven't specified the port number in the second url.
 
Jim Babcock
Ranch Hand
Posts: 55
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I had it there, but took it out because the bean code that does work, doesn't have it. *shrug*
 
craig a chapman
Greenhorn
Posts: 27
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Does the remote database have connections via TCP/IP enabled? You can change this setting through MySQL administrator -> Startup Variables -> General Parameters. I think it's disabled by default.
 
craig a chapman
Greenhorn
Posts: 27
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Scrap that last comment. I just remembered you have managed to connect with your bean.
 
Ranch Hand
Posts: 1683
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I don't know if this is the cause of your problem, but shouldn't your JDBC environment subcontext be:
 
Jim Babcock
Ranch Hand
Posts: 55
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I tried it, but it didn't change things. I didn't think it would, becuase I'd fat fingered the IP and it complained and went back to this error when I fixed it.
 
Jim Babcock
Ranch Hand
Posts: 55
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Excuse me while I punch myself in the head... I had the IP number wrong all this time. Apparently the one I used is a valid machine, because as I said above, I'd fat fingered the last octet as 384 and it didn't work. The thing is we have a million and six IP ranges internally, and the 3rd octet should have been 16 not 1. I vi'ed and stared at content.xml one more time and it just jumped out at me.

*whump* *whump* *whump*

Jimbus
 
reply
    Bookmark Topic Watch Topic
  • New Topic