Win a copy of Functional Reactive Programming this week in the Other Languages forum!
    Bookmark Topic Watch Topic
  • New Topic

Problem with struts 1.2.7 and later versions on Weblogic 8.1

 
dee sri
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Report post to moderator
I have a trade application which was using struts version 1.2.1.
Now I upgraded it to 1.2.7 with the proper upgrade libraries.
I deploy it in weblogic as an ear file which in turn has trade.war file.
The login.jsp throws an error

/common/taglibs.jsp(3): Error in using tag library uri='http://struts.apache.org/tags-html' prefix='html': The Tag class 'org.apache.struts.taglib.html.CheckboxTag' has no setter method corresponding to TLD declared attribute 'errorKey', (JSP 1.1 spec, 5.4.1)
probably occurred due to an error in /common/taglibs.jsp line 3:
<%@ taglib uri="http://struts.apache.org/tags-html" prefix="html" %>

My taglibs.jsp just have references to the tlds as below
<%@ taglib uri="http://struts.apache.org/tags-bean" prefix="bean" %>
<%@ taglib uri="http://struts.apache.org/tags-html" prefix="html" %>
<%@ taglib uri="http://struts.apache.org/tags-logic" prefix="logic">

I checked the struts.jar and tlds, in which the checkboxtag has setter methods. Is it something to do with the jsp 1.1 version which the weblogic 8.1 is supporting?Please reply
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 65223
95
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Report post to moderator
Please do not cross-post the same question in multiple forums. It wastes people's time when multiple redundant conversations take place.

And please do not post questions in forums that it has nothing to do with.
 
    Bookmark Topic Watch Topic
  • New Topic