• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

Problem in Jbuilder 4.0

Ranch Hand
Posts: 362
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have written a simple stateful EJB in Jbuilder4.0.
When I comile the projext it gives the following error.Pl tell me if I have to make any settings before building the project.The error is as follows

"sampleEJB.ejbgrp": java.io.IOException: CreateProcess: E:/docs/bin/bcjW -classpath E:\JBuilder4\jdk1.3\jre\lib\rt.jar;E:\JBuilder4\jdk1.3\jre\lib\i18n.jar;E:\JBuilder4\jdk1.3\jre\lib\sunrsasign.jar;E:\JBuilder4\jdk1.3\jre\classes;D:\weblogic\examples\sampleEJb\cl asses;E:\inprise\lib\vbdev.jar;E:\inprise\lib\vbejb.jar;E:\inprise\lib\vbjdev.jar;E:\inprise\lib\vbjorb.jar;E:\inprise\lib\navigator.jar;D:\weblogic\classes;D:\weblogic\classes\boo t;D:\weblogic\lib\weblogicaux.jar;D:\weblogic\lib\persistence\WebLogic_RDBMS.jar;E:\JBuilder4\jdk1.3\demo\jfc\Java2D\Java2Demo.jar;E:\JBuilder4\jdk1.3\jre\lib\i18n.jar;E:\JBuilder4 \jdk1.3\jre\lib\jaws.jar;E:\JBuilder4\jdk1.3\jre\lib\rt.jar;E:\JBuilder4\jdk1.3\jre\lib\sunrsasign.jar;E:\JBuilder4\jdk1.3\lib\dt.jar;E:\JBuilder4\jdk1.3\lib\tools.jar;D:\weblogic\ examples\sampleEJb\sampleEJB.jar.jar;C:\TEMP\ejbcgen;;C:\TEMP\ejbcgen;;C:\TEMP\ejbcgen -d C:\TEMP\ejbcgen C:\TEMP\ejbcgen\examples\sampleejb\sampleBeanHomeImpl.java C:\TEMP\ejbcgen\examples\sampleejb\sampleBeanEOImpl.java error=2
"sampleEJB.ejbgrp": at java.lang.Win32Process.create(Native Method)
"sampleEJB.ejbgrp": at java.lang.Win32Process.<init>(Win32Process.java:66)
"sampleEJB.ejbgrp": at java.lang.Runtime.execInternal(Native Method)
"sampleEJB.ejbgrp": at java.lang.Runtime.exec(Runtime.java:551)
"sampleEJB.ejbgrp": at java.lang.Runtime.exec(Runtime.java:477)
"sampleEJB.ejbgrp": at java.lang.Runtime.exec(Runtime.java:443)
"sampleEJB.ejbgrp": at weblogic.utils.Executable.exec(Executable.java:151)
"sampleEJB.ejbgrp": at weblogic.utils.Executable.exec(Executable.java:88)
"sampleEJB.ejbgrp": at weblogic.utils.compiler.CompilerInvoker.compileMaybeExit(CompilerInvoker.java:380)
"sampleEJB.ejbgrp": at weblogic.utils.compiler.CompilerInvoker.compile(CompilerInvoker.java:220)
"sampleEJB.ejbgrp": at weblogic.utils.compiler.CompilerInvoker.compile(CompilerInvoker.java:211)
"sampleEJB.ejbgrp": at weblogic.ejb.ejbc.EJBCompiler.compileEJB(EJBCompiler.java:171)
"sampleEJB.ejbgrp": at weblogic.ejbc.runBody(ejbc.java:307)
"sampleEJB.ejbgrp": at weblogic.utils.compiler.Tool.run(Tool.java:80)
"sampleEJB.ejbgrp": at weblogic.ejbc.main(ejbc.java:353)
"sampleEJB.ejbgrp": Exec failed .. exiting

Pl reply
Thanx in advance
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have seen this error before when trying to run WebLogic's ejbc from a command line, but never when just compiling from in JB4. The problem for us seemed to be related to using the "wrong" compiler. We specifically used the compiler packaged with WebLogic 6.0 and that fixed it. WebLogic 6.0 requires that you use a JDK with the HotSpot VM, so make sure whatever version you are using will work.
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
EJBC tries to kick off javac, and error 2 must be the numeric equivalent of the familiar message:
The name specified is not recognized as an
internal or external command, operable program or batch file.
I experienced the same error, and fixed it by adjusting my path to properly include the jdk\bin directory. (I was using a network directory, and someone moved it away without telling me - but "java" worked since it was also in C:\windows - just "javac" didn't work since it wasn't anywhere in the path any more.)
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I discovered that Java does not like spaces in directory names and uninstalled JBuilder from C:\Program Files\JBuilder and reinstalled it under C:\JBuilder6.
I kept getting the error you describe, even after a new re-install and creating new projects.
Here's what fixed the problem:
Inside JBuilder 6
Tools/Configure jdks
Change "JDK HomePath" to the new location.
(For me it was "C:\JBuilder6\jdk1.3.1")
Change all the settings in the Class, Source, and Documentation tabs.
That fixed the problem for me.
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!