• Post Reply Bookmark Topic Watch Topic
  • New Topic

Connection not available  RSS feed

Lalit mishra
Ranch Hand
Posts: 100
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am facing following problem
Sometimes i am able to get database connection (Oracle database) and
my application works fine.But next time i run the same application i get following exception.
java.sql.SQLException: Io exception: Connection refused(DESCRIPTION=(TMP=)(VSNNUM=153093120)(ERR=12519)(ERROR_STACK=(ERROR=(CODE=12519)(EMFI=4))))
at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:134)
at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:179)
at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:334)
at oracle.jdbc.ttc7.TTC7Protocol.handleIOException(TTC7Protocol.java:3695)
at oracle.jdbc.ttc7.TTC7Protocol.logon(TTC7Protocol.java:352)
at oracle.jdbc.driver.OracleConnection.<init>(OracleConnection.java:362)
at oracle.jdbc.driver.OracleDriver.getConnectionInstance(OracleDriver.java:536)
at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:328)
at java.sql.DriverManager.getConnection(DriverManager.java:559)
at java.sql.DriverManager.getConnection(DriverManager.java:211)
at com.iflex.fcat.infra.JFGlobalFunctions.getConnection(JFGlobalFunctions.java:2014)
at com.iflex.fcat.infra.JFGlobalFunctions.getConnection(JFGlobalFunctions.java:1933)
at com.iflex.fcat.infra.JFGlobalMessages.loadMessages(JFGlobalMessages.java:193)
at com.iflex.fcat.infra.JFProperties.loadPropertiesFromDB(JFProperties.java:341)
at com.iflex.fcat.infra.JFProperties.loadProperties(JFProperties.java:311)
at com.iflex.fcat.apps.DexiReconcilation.initializeClass(DexiReconcilation.java:529)
at com.iflex.fcat.apps.DexiReconcilation.run(DexiReconcilation.java:662)
at java.lang.Thread.run(Thread.java:570)

Thanks in advance
Malith Yapa
Ranch Hand
Posts: 45
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It is quite hard to say with the information you've provided.. Please post how you exactly tried to get the connection..

However if this error occured in a webapp.. It may be because the server is clustered.. That way only the instance that created the database can use it.. Requests sent through the other instance would not be processed.. Well i thought so because that's one way that it could work only sometimes.. Please make your posts in more detail..

The exception is not familiar to me.. I haven't used oracle anyways.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!