Win a copy of Java Mock Exams (software) this week in the Programmer Certification (OCPJP) forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Problem with stored procedure table parameter

 
Rafal Mrozik
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello, I have the problem with stored procedure with paramater which is table type.

I have defined my own type


and i have stored procedure like this



Now...

When I run this class on my local machine the result is OK nad looks like
1: 'ONE'
2: 'TWO'
3: 'THREE'

But when I copy this class on the server and run it, the result is wrong
1: '???'
2: '???'
3: '???'

Here is my environment:

on local machine
eclipse 3.3.1
java 1.5 (java version compiler in eclipse is 1.4)

on server (WAS 5)
oracle 9.2.0.6.0
java 1.4.2_08

Result from table parameters are always 3 question marks :|
What is the problem?
 
Rafal Mrozik
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hmm I think i found the solution: nls_charset12.jar from page
http://www.oracle.com/technology/software/tech/java/sqlj_jdbc/htdocs/jdbc9201.html
I have copied this jar to WAS lib directory and it works fine
 
Raghavan Muthu
Ranch Hand
Posts: 3381
Mac MySQL Database Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thats great Rafal Mrozik. :thumb:

Welcome to JavaRanch
 
Happiness is not a goal ... it's a by-product of a life well lived - Eleanor Roosevelt. Tiny ad:
the new thread boost feature: great for the advertiser and smooth for the coderanch user
https://coderanch.com/t/674455/Thread-Boost-feature
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!