• Post Reply Bookmark Topic Watch Topic
  • New Topic

Problem In Starting J2EE

 
Smita Jain
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I am having a problem in starting J2EE server.
I am having jdk 1.2.2 and OS as Windows Millennium Edition. I have set the class path but when I am typing j2ee -verbose I am getting this message :
Out of environment space
Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/enterprise/se
rver/J2EEServer
Can anyone help me in this regard.
Thanks in advance,
smita
 
rak146
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Smita
Please check the classpath you have set. It should have all the jar files which is present in lib directory i.e ejb10deployment.jar, jhall.jar and j2ee.jar.
After setting it, it will be ok.
Bye
Rakesh

 
akilan kandaswamy
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hai,
To run ejb u should have atleast 128MB ram space.I think because of this problem u are getting such a message.
 
hanumanth reddy
Ranch Hand
Posts: 118
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

set path to J2EE/bin in addition to all all the Environment Settings as mentioned in The Docs it will works
all the best smitha
 
Anjana Rao
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
dear samitha,
i think so you have not set two variables in your enviornment...one needs to be JAVA_HOME and other needs to J2EE_HOME...set the classpath with these variables....i had faced the same problem....
anjana
 
Smita Jain
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi there,
Thanx to all. I could solve the problem. Actually I had to change the environment of Command prompt.
But now I am facing another problem like I am following the documentation of J2EE. It's asking me to go to j2sdkee1.2.1\doc\guides\ejb\examples\converter and run complileEJB(a MS-DOS prompt file). But I am getting errors in importing all the pakages.That means my classpath is not set.But I have set my class path. The following are present in my autoexec.bat file
SET PATH=C:\JDK1.2.2\BIN;C:\J2SDKEE1.2.1\BIN;
SET CLASSPATH=c:\jdk1.2.2\lib;.;c:\j2sdkee1.2.1\lib\j2ee.jar;
SET JAVA_HOME=C:\jdk1.2.2
SET J2EE_HOME=c:\j2sdkee1.2.1
I am getting following message while running compileEJB :
ConverterHome.java:12: Class javax.ejb.CreateException not found in import.
import javax.ejb.CreateException;
^
ConverterHome.java:13: Class javax.ejb.EJBHome not found in import.
import javax.ejb.EJBHome;
^
ConverterHome.java:15: Interface javax.ejb.EJBHome of interface ConverterHome no
t found.
public interface ConverterHome extends EJBHome {
^
Converter.java:10: Class javax.ejb.EJBObject not found in import.
import javax.ejb.EJBObject;
^
Converter.java:13: Interface javax.ejb.EJBObject of interface Converter not foun
d.
public interface Converter extends EJBObject {
^

Could anyone tell where am I going wrong.
Smita
 
sandy gupta
Ranch Hand
Posts: 228
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I dunno anything bout J2EE server but there is a classpath problem in u'r application. Remember a rule of thumb. Whenever and wherever u set the classpath, put ;%classpath% in the end. ALWAYS. Ok . I know u must be starting in the industry and everybody learns sometime or the other. Now u do that where u are setting the classpath and for checking whether u'r files are in the classpath, open the jars and chk its content and try to locate the class file in the package where it is mentioned it shud be.
HTH
Sahil
 
Rahul Bansal
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
even i encountered the same problem at the beginning ....the problem is that ur class file(bean) is not getting the supporting files pakaged in javax.ejb....which are present in
j2ee.jar.....just check out the location of it whether it is present in accordance with ur classpath settings...alternatively copy and paste the package in the same folder as ur files are in
hope it will help
------------------
 
hanumanth reddy
Ranch Hand
Posts: 118
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
include all jar in your classpath available in your j2ee/bin directory
 
shailesh sonavadekar
Ranch Hand
Posts: 1874
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
rak146 , Welcome to javaranch.
PROPER NAMES ARE NOW REQUIRED
Please refer to Official Javaranch Naming Policy & reregister yourself with proper first & last name. Please follow the naming policy & help maintain the decorum of the forum.
Waiting for your post with proper rergistered name.

YOur Friendly Bartender
Shailesh


[This message has been edited by shailesh sonavadekar (edited March 13, 2001).]
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!