• Post Reply Bookmark Topic Watch Topic
  • New Topic

passivation of EJB

 
Zhongwu Lin
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
situation:
I have a session bean which has a method. In this method I create an entity bean A ( to insert a record in DB).
The settings are as follows:
The session bean has transaction type = "Container"
and all methods of the session bean has "required" as transaction attribute

Problem:
I found that I have 4500 instances of entity bean A. In other word, container never passivate my entity bean.
I am using Inprise App server 4.1. I use default setting for Garbage collection from inprise, i.e. min and max heap size = 32MB for container
Is this a bug in App server? or I did something wrong?
your help will be very much appreciated.
Zhongwu
 
Zhongwu Lin
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I found the solution. It is a bug in Inprise app server. The default setting of MaxBeansinPool = 1000 is not working.

Thanks
Zhongwu
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!