• Post Reply Bookmark Topic Watch Topic
  • New Topic

How to start J2EE server ?  RSS feed

 
SenthilKumar Natarajan
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I set all the environmental variables as given in Doc's.
When i run the bat file "j2ee" it gives the following message,
e:\j2ee\bin>j2ee

J2EE server Listen Port: = 1049
Redirecting the output and error streams to the following files:
e:\j2ee\logs\senthil\ejb\j2ee\system.out
e:\j2ee\logs\senthil\ejb\j2ee\system.err
e:\j2ee\bin>
when i tried to deploy the project, following error is coming
"please connect to a server inorder to deploy."
If anyone know the solution help me what to do further.
 
Harpal Singh
Ranch Hand
Posts: 229
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear Senthil,
Start the j2ee server with -verbose option i.e. j2ee -verbose
it will give you a proper message abt why the server is not starting....
Thanks,
Harpal
 
SenthilKumar Natarajan
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear Harpal,
When I tried as
E:\j2ee\bin>j2ee -verbose
java.lang.RuntimeException: Could not initialize j2ee server. Possible cause cou
ld be another instance of the server already running.
at com.sun.enterprise.iiop.POAProtocolMgr.initializeNaming(POAProtocolMg
r.java:118)
at com.sun.enterprise.server.J2EEServer.run(J2EEServer.java:244)
at com.sun.enterprise.server.J2EEServer.main(J2EEServer.java:866)
java.lang.RuntimeException: Could not initialize j2ee server. Possible cause cou
ld be another instance of the server already running.
at com.sun.enterprise.server.J2EEServer.run(J2EEServer.java:348)
at com.sun.enterprise.server.J2EEServer.main(J2EEServer.java:866)
J2EE server reported the following error: Could not initialize j2ee server. Poss
ible cause could be another instance of the server already running.
Error executing J2EE server ...
Error is coming as above.
Senthil
 
Prashant Jani
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
HI,
I am sure you have done the settings for the classpath.
well first try to run : j2ee -stop
This will stop any instance of the server. then you can start the server using j2ee -verbose (recommended).
You cannot start another instance if the server is already on. ( You must not have shut down the server ).
Always properly shut down the server j2ee -stop.
Do not try to kill the process using ctrl C or end process.
 
SenthilKumar Natarajan
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
Good. I did that already. When i am trying to stop the server by giving
prompt>j2ee -stop
the following error is coming
Unable to shutdown the J2EE server.
Pl. tell me any other option to stop the server.

[This message has been edited by SenthilKumar Natarajan (edited March 30, 2001).]
 
Richard Chu
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I got the same thing happened today. Just wondering if you have any chance to solve that. If so, please give me the instruction. If not, I'll keep you post if I find one.
Thanks!
 
Peter Gragert
Ranch Hand
Posts: 424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It depends on your operating system.
Under NT4 I do as follows:
ctrl-alt-del keys

(all at once) choose :Task Manager
then you can kill jobs(you started, others are dangerous :-)).

[This message has been edited by Peter Gragert (edited April 27, 2001).]
 
Clayton Webb
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The reason that you are getting an error in trying to shut the server down is because it is probably not running. You most likely have another server listening on one of the ports that j2ee is trying to listen on. The fix is to either stop the other server or change the ports that one of them is listening on. To do this in j2ee, go into the config directory and modify the property files. Just a guess, but you probably have another web server listening on port 8000. You will need to change the web.properties file in that case.
Hope this helps.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!