Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

J2EE Account example with SQL Server

 
Richard Chu
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
Im trying the J2EE Account example in Windows 2000 server. I don't want to use Cloudscape (because cloudscape is not working in my machine). I'd like to try it in MS SQL Server 2000. I'm thinking just use JDBC-ODBC bridge for testing. How should I configure the J2EE server. If anyone can provide step-by-step instruction, I appreciate it.

Richard
 
Mike Curwen
Ranch Hand
Posts: 3695
IntelliJ IDE Java Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
In your j2sdkee1.2.1 directory, find this document:
doc\release\ConfigGuide.html

In this document (page 2 and 3), are instructions for setting up alternate databases.

Long story short: I tried to use MySQL because Cloudscape wouldn't work. Couldn't get either to work. Then I finally got Cloudscape to work, and went *back* to see if I could 'easily' swap databases. When I followed the instructions in this document, not only would MySQL *still* not work but the *other* applications also failed (the ones still using Cloudscape). So I finally gave up and just used the (now working) Cloudscape.

Note: I finally got Clouscape working by upgrading. Here is the URL for instructions: http://www.cloudscape.com/support/servepage.jsp?page=fyi_j2ee.html

Hope that helps. Let us know how you make out with SQLS2k
[This message has been edited by Mike Curwen (edited April 18, 2001).]
 
ramya
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi,
i am also trying to run the account example in j2ee with
merant sqlserver driver.
i have set the paths in default.properties,,and the bean was deployed successfully..but when i run the accountclient..it give
me Rmi Exception can't create Entity EJB..
what may be the problem?
whether i haven't set the default.properities properly ..
please help
ramya
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic