• Post Reply Bookmark Topic Watch Topic
  • New Topic

Need help in installing J2EE

 
radhika madini
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I am interested in learning EJB.So I downloaded j2sdkee1.3 on win98.
my path settings in autoexe are
set TOMCAT_HOME=c:\tomcat
set JAVA_HOME=c:\jdk1.3
set J2EE_HOME=c:\j2sdkee1.3
SET PATH=C:\JDK1.3\BIN; c:\j2sdkee1.3\bin;%PATH%
set classpath=c:\jdk1.3\lib\tools.jar;c:\j2sdkee1.3\lib\j2ee.jar
set path=%path%;c:\tomcat\bin
Set CLASSPATH=.;%TOMCAT_HOME%\lib\servlet.jar
set classpath=c:\jsdk2.0\lib\jsdk.jar;
For testing
when I type j2ee -verbose on dos prompt it sets the path and displays cursor..
when I type deploytool on dos prompt it is saying that J2EE_HOME is not found.
I need help in running EJB's..
I do not have web logic in my system yet..
please guide me in installing and using J2EE
Thanks
Radhika Madini
 
Peter Gragert
Ranch Hand
Posts: 424
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hallo,
Look into the batchfiles in
\j2sdkee1.3\bin\deploytool.bat (and the batchfiles this one is referring to!)
There you can fill in all the required pathes etc.
At least so I have done (though on NT4)
 
Shibin Raghavan
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Radhika,
U have to set the path for JAVA_HOME and J2EE_HOME in the 'userconfig.bat' file, which is in the 'bin' folder.
Just run this file in the console window in which u r going to run the j2ee server and also the deploytool.
Thats it...
Bye...
Regards,
Shibs
 
Brogan
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I notice your classpath settings are not formatted correctly: you wrote
set classpath=c:\jdk1.3\lib\tools.jar;c:\j2sdkee1.3\lib\j2ee.jar
Set CLASSPATH=.;%TOMCAT_HOME%\lib\servlet.jar
set classpath=c:\jsdk2.0\lib\jsdk.jar;
which would cause the classpath environment variable to be overriden. As with the path command, you should format the latter two classpath statements thus:
Set CLASSPATH=%classpath%;.;%TOMCAT_HOME%\lib\servlet.jar
set classpath=%classpath%;c:\jsdk2.0\lib\jsdk.jar
Probably a minor slip, but these things can cause grief!
B.J.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!