Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Orion initial settings  RSS feed

 
Vladimir Kositsky
Ranch Hand
Posts: 116
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!
I am working over example http://www.jollem.com/orion-cmp-primer/
Please let me know what the exact syntax of <application> path in
orion/config under win98 . I am using
path="file:c:/.../addressbook/build/addressbook.ear"
Orion directory c:\orion.
My autoexec.bat is:
...
PATH C:\WINDOWS;C:\WINDOWS\COMMAND;C:\j2sdkee1.3\bin;C:\ANT\BIN;C:\MSSQL7\BINN;C:\TOMCAT\BIN;C:\ORION
SET TOMCAT_HOME=c:\tomcat
SET JAVA_HOME=C:\jdk1.3.0_02
SET J2EE_HOME=C:\j2sdkee1.3
SET ANT_HOME=C:\ant
SET ORION_HOME=c:\orion

SET PATH=%PATH%;C:\GRAVIS\PCGPPro
REM - By Windows Setup - SET SNDSCAPE=C:\WINDOWS
SET SNDSCAPE=C:\WINDOWS
Set
CLASSPATH=.;C:\tomcat\lib\servlet.jar;C:\tomcat\lib\jasper.jar;C:\jdk1.3.0_02\ib\tools.jar;C:\orion\ejb.jar;C:\j2sdkee1.3\lib\j2ee.jar
I included C:\orion\ejb.jar to classpath becouse I had a problem to
compile without it.
Whether i need to change something?
Thanks

Thanks

 
Sergei Voropay
Ranch Hand
Posts: 31
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The classpath settings are irrelevant for Orion considering the fact that that it builds its own classpath from the manifest in the orion.jar file. One important point in keep in mind when trying to run orion is having tools.jar in the orion installation directory, otherwise it should do it.
For compiling purposes you better off including the following jar files in your classpath: orion.jar, ejb.jar, jndi.jar, jdbc.jar, jaxp.jar, parser.jar, mail.jar, crimson.jar, activation.jar. Try to set the above-mentioned jar files ahead of j2ee.jar in the classpath because it is known to cause problems if compiler uses some of j2ee.jar classes instead of orion's.
Hope it helps.
 
Vladimir Kositsky
Ranch Hand
Posts: 116
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for reply,
did you mean that classpath should better include orion.jar, ejb.jar, jndi.jar, jdbc.jar, jaxp.jar,parser.jar, mail.jar, crimson.jar, activation.jar. ?
 
Sergei Voropay
Ranch Hand
Posts: 31
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What I mean is Orion doesn't need you to specify the classpath at all -- you can use a classpath set to a zero-length string, Orion will use the classpath defined in the jar manfiest. But if you are building servlets, EJB's, EJB application clients, etc. that involve Orion class implementations, then you need to specify those jar files I talked about to compile your classes.
Sorry, may be I'm being a little confusing.
 
Vladimir Kositsky
Ranch Hand
Posts: 116
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It is clear now.
I cannot find syntax for setting of absolute path in orion/config/server.xml:
appliction name = "addressbook" <application name="addressbook" path="C:/Work/Addressbook/addressbook/build/addressbook.ear" >
does not work, path="file:C:/Work/Addressbook/addressbook/build/addressbook.ear"
allowed to initialize the server, but I not sure that right expression for XML
Thanks for help
[This message has been edited by Vladimir Kositsky (edited May 08, 2001).]
[This message has been edited by Vladimir Kositsky (edited May 08, 2001).]
[This message has been edited by Vladimir Kositsky (edited May 08, 2001).]
[This message has been edited by Vladimir Kositsky (edited May 08, 2001).]
 
Sergei Voropay
Ranch Hand
Posts: 31
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Path should be set like this: path="C:\Work\Addressbook\addressbook\build\addressbook.ear"
 
Vladimir Kositsky
Ranch Hand
Posts: 116
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks again, Sergei.
Server run testing application. I do not know what was exact problem and where i was wrong.
But finally i reinstall server, rewrite autoexec.bat and it is working now.
Good luck!
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!