• Post Reply Bookmark Topic Watch Topic
  • New Topic

whatever I tried, can't start j2ee, help who have experience.

 
fan mo
Ranch Hand
Posts: 36
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am using window 2000. jdk1.3 j2sdkee1.3
JRun, all other applications have been shut down .
I have check all previous j2ee set classpath install threads and followed them but still error saying there's another process listening the port no matter what port No. I changed to.
in autoexec.bat:
SET J2EE_HOME=C:\j2sdkee1.3
SET JAVA_HOME = C:\jdk1.3
set J2EE_CLASSPATH=%J2EE_HOME%\lib
set path=%PATH%;C:\JDK1.3\BIN;c:\;C:\j2sdkee1.3\bin;
set CPATH=.;%J2EE_HOME%\lib\j2ee.jar;
set classpath = %classpath%;C:\JDK1.3\lib;C:\j2sdkee1.3\lib\j2ee.jar;C:\j2sdkee1.3\lib\ejb10deployment.jar;C:\j2sdkee1.3\lib\jhall.jar;
J2EE server listen port has been changed many times in orb.properties file.
the result always is:
C:\j2sdkee1.3\bin>j2ee -verbose
J2EE server listen port: 1775
org.omg.CORBA.INTERNAL: minor code: 1398079697 completed: No
at com.sun.corba.ee.internal.iiop.GIOPImpl.createListener(GIOPImpl.java:
253)
at com.sun.corba.ee.internal.iiop.GIOPImpl.getEndpoint(GIOPImpl.java:202
)
at com.sun.corba.ee.internal.iiop.GIOPImpl.initEndpoints(GIOPImpl.java:1
37)
at com.sun.corba.ee.internal.POA.POAORB.getServerEndpoint(POAORB.java:48
4)
at com.sun.corba.ee.internal.POA.POAImpl.pre_initialize(POAImpl.java:144
)
at com.sun.corba.ee.internal.POA.POAImpl.<init>(POAImpl.java:102)
at com.sun.corba.ee.internal.POA.POAORB.makeRootPOA(POAORB.java:109)
at com.sun.corba.ee.internal.POA.POAORB$1.evaluate(POAORB.java:127)
at com.sun.corba.ee.internal.core.Future.evaluate(Future.java:23)
at com.sun.corba.ee.internal.corba.ORB.resolveInitialReference(ORB.java:
2159)
at com.sun.corba.ee.internal.corba.ORB.resolve_initial_references(ORB.ja
va:2110)
at com.sun.enterprise.server.J2EEServer.run(../../src/share/com/sun/ente
rprise/server/J2EEServer.java:192)
at com.sun.enterprise.server.J2EEServer.main(../../src/share/com/sun/ent
erprise/server/J2EEServer.java:901)
java.lang.RuntimeException: Unable to create ORB. Possible causes include TCP/IP
ports in use by another process
at com.sun.enterprise.server.J2EEServer.run(../../src/share/com/sun/ente
rprise/server/J2EEServer.java:202)
at com.sun.enterprise.server.J2EEServer.main(../../src/share/com/sun/ent
erprise/server/J2EEServer.java:901)
java.lang.RuntimeException: Unable to create ORB. Possible causes include TCP/IP
ports in use by another process
at com.sun.enterprise.server.J2EEServer.run(../../src/share/com/sun/ente
rprise/server/J2EEServer.java:202)
at com.sun.enterprise.server.J2EEServer.main(../../src/share/com/sun/ent
erprise/server/J2EEServer.java:901)
java.lang.RuntimeException: Unable to create ORB. Possible causes include TCP/IP
ports in use by another process
at com.sun.enterprise.server.J2EEServer.run(../../src/share/com/sun/ente
rprise/server/J2EEServer.java:347)
at com.sun.enterprise.server.J2EEServer.main(../../src/share/com/sun/ent
erprise/server/J2EEServer.java:901)
J2EE server reported the following error: Unable to create ORB. Possible causes
include TCP/IP ports in use by another process
Error executing J2EE server ...
Anyone have the same experience, please let me know. been stuck here for several days. Thanks so much!
fan
 
vinoo
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
Could you solve it i am facing dito problem
could you please tell me the solution to this if u could solve
it
please mail me at
vinoo.das@ehpt.com
J2EE server listen port: 2000
org.omg.CORBA.INTERNAL: minor code: 1398079697 completed: No
at com.sun.corba.ee.internal.iiop.GIOPImpl.createListener(GIOPImpl.java:256)
at com.sun.corba.ee.internal.iiop.GIOPImpl.getEndpoint(GIOPImpl.java:205)
at com.sun.corba.ee.internal.iiop.GIOPImpl.initEndpoints(GIOPImpl.java:140)
at com.sun.corba.ee.internal.POA.POAORB.getServerEndpoint(POAORB.java:488)
at com.sun.corba.ee.internal.POA.POAImpl.pre_initialize(POAImpl.java:154)
at com.sun.corba.ee.internal.POA.POAImpl.<init>(POAImpl.java:112)
at com.sun.corba.ee.internal.POA.POAORB.makeRootPOA(POAORB.java:110)
at com.sun.corba.ee.internal.POA.POAORB$1.evaluate(POAORB.java:128)
at com.sun.corba.ee.internal.core.Future.evaluate(Future.java:21)
at com.sun.corba.ee.internal.corba.ORB.resolveInitialReference(ORB.java:2421)
at com.sun.corba.ee.internal.corba.ORB.resolve_initial_references(ORB.java:2356)
at com.sun.enterprise.server.J2EEServer.run(J2EEServer.java:193)
at com.sun.enterprise.server.J2EEServer.main(J2EEServer.java:913)
java.lang.RuntimeException: Unable to create ORB. Possible causes include TCP/IP ports in use by another process
at com.sun.enterprise.server.J2EEServer.run(J2EEServer.java:203)
at com.sun.enterprise.server.J2EEServer.main(J2EEServer.java:913)
java.lang.RuntimeException: Unable to create ORB. Possible causes include TCP/IP ports in use by another process
at com.sun.enterprise.server.J2EEServer.run(J2EEServer.java:203)
at com.sun.enterprise.server.J2EEServer.main(J2EEServer.java:913)
java.lang.RuntimeException: Unable to create ORB. Possible causes include TCP/IP ports in use by another process
at com.sun.enterprise.server.J2EEServer.run(J2EEServer.java:350)
at com.sun.enterprise.server.J2EEServer.main(J2EEServer.java:913)
J2EE server reported the following error: Unable to create ORB. Possible causes include TCP/IP ports in use by another proces
s
Error executing J2EE server ...

 
syed samad
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
dear fan mo
its very easy to run j2ee, first of all as u said that u r
using windows 2000, so u don't have to write
set JAVA_HOME
set J2EE_HOME
in ur autoexec.bat file, these r environments variables,
the best way to write environments variables in windows 2000 or windows nt is,
right click to my computer on ur desktop
click properties
click the 'advance' tab and u will see enviroment variable button
click it
a window will come click new button a small window come
write JAVA_HOME in texfield 'name'
write c:\jdk1.3 or path u have in textfield 'value'
write J2EE_HOME in texfield 'name'
write c:\j2sdkee1.2.1 or path u have in textfield 'value'
and write this in ur autoexec.bat file
remember ur ram should be 128 or more
set path=%path%;%JAVA_HOME%\BIN;%J2EE_HOME%\BIN;
set classpath=%JAVA_HOME%\LIB\TOOLS.JAR;JAVA_HOME\LIB\DT.JAR;
%J2EE_HOME%\LIB\j2ee.jar;%J2EE_HOME%\LIB\CLOUDSCAPE\TOOLS.JAR;%J2EE_HOME%\LIB\CLOUDSCAPE\CLIENT.JAR;%J2EE_HOME%\LIB\CLOUDSCAPE\CLOUDSCAPE.JAR;
hope this will work

syed samad
 
Manisha S C
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You could try the following solution that worked for me
C:\j2sdkee1.3\bin\setenv.bat contains the following
set LISTEN_OPTIONS=-Dcom.sun.CORBA.connection.ORBListenSocket=SSL:0,SSL_MUTUALAUTH:0,PERSISTENT_SSL:1060
try modifing 1060 to something else
In my case "netstat /a" showed port 1060 in use, so I changed
1060 to 2060 and now everything works just fine
-----------------------------------------------
Sun Certified Programmer on the Java 2 Platform
 
Deepak Mahbubani
Ranch Hand
Posts: 68
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I solved this problem in Win Nt Workstation 4.0 as :
1. Shutdown Server under Settings->Control Panel -> Services -> Server

------------------
 
Anonymous
Ranch Hand
Posts: 18944
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Download Windows 2000 SP2.
 
Anonymous
Ranch Hand
Posts: 18944
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Manisha S C:
You could try the following solution that worked for me
C:\j2sdkee1.3\bin\setenv.bat contains the following
set LISTEN_OPTIONS=-Dcom.sun.CORBA.connection.ORBListenSocket=SSL:0,SSL_MUTUALAUTH:0,PERSISTENT_SSL:1060
try modifing 1060 to something else
In my case "netstat /a" showed port 1060 in use, so I changed
1060 to 2060 and now everything works just fine

Hi!
Just want to let you know, that this is excactly what does the trick. Thanx,
S�ren
 
Simon Brown
sharp shooter, and author
Ranch Hand
Posts: 1913
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I usually find shutting down apps such as instant messengers, e-mail apps, etc does the trick too.
"vinoo",
Could you please take a quick look at the JavaRanch naming policy and edit your profile accordingly.
Thanks
Simon
[ July 17, 2002: Message edited by: Simon Brown ]
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!