Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

basic Problem

 
Ranch Hand
Posts: 41
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
HI All !
I am new to j2ee environment and so have a simple problem. I have downloaded j2sdkee 1.3 from the sun's site and have also installed it on my computer (running windows 2000 server). After setting all the possible paths it is still gving me this error-"invalid path ! set J2EE_HOME to the j2ee installation directory"
I have changed the path in system enviroment and also in userconfig.bat file in the bin directory. But still it is not reading it. What to do now???
Thank you !
manoj
 
Saloon Keeper
Posts: 22490
151
Android Eclipse IDE Tomcat Server Redhat Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
J2EE_HOME isn't a "path" - it's an environment variable whose value you need to set to be the absolute pathname of the directory where J2EE is installed.
 
Ranch Hand
Posts: 1871
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Just check up if this helps

I however have j2sdkee1.2.1
------------------

Mahindrakar
IBM Application Server Forum Moderator
Consultant - Zensar Technologies.
SCJP2, SCJD2 & SCJEA (Part I)
 
Ranch Hand
Posts: 236
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Hello Manoj,
The reason could be..
you have given a white space(s) somewhere when setting the
J2EE_HOME value.Do not give any spaces.It should look like
this. set J2EE_HOME=c:\j2sdkee1.3
Hope this helps,
Manjunath
 
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Manoj Singh
you better don't go to userconfig.bat
just type the path environment what ever it requires
start with
c:\j2sdkee1.3\>cd bin
c:\j2sdkee1.3\bin>set J2EE_HOME=c:\j2sdkee1.3
c:\j2sdkee1.3\bin>set JAVA_HOME=c:\jdk1.2.2
c:\j2sdkee1.3\bin>j2ee
i hope NO PROBLEMS..
DO REPLY ME
captain_sonil@yahoo.com
 
Ranch Hand
Posts: 48
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Rahul ,Sunil;
After setting the paths and starting the server when i try point my browser to http://localhost:1049/ the browser just hangs.
What must be prolem?

My another problem was my j2sdkee1.2.1 is compiling the java files i.e
but when i try to run it by java add it gives following error
Registry key 'Software\JavaSoft\Java Runtime Environment\CurrentVersion'
has value '1.1', but '1.2' is required.
Whats the solution.
Thanks in advance.
Harshad
 
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi
create one .bat file like "som.bat".Before running u r j2ee server run the bat file.
set path=c:\jdk1.3\bin;c:\j2sdkee1.2.1\bin;
set classpath=c:\jdk1.3\lib\tools.jar;c:\j2sdkee1.2.1\lib\j2ee.jar;
set java_home =c:\jdk1.3
set j2ee_home =c:\j2sdkee1.2.1
som
 
sunil seth
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
c:\j2sdkee1.2.1\bin>deploytool
this will automatically opens a window for deployment
then process your deployment
second problem:
you are getting the error like
Registry key 'Software\JavaSoft\Java Runtime Environment\CurrentVersion'
has value '1.1', but '1.2' is required.
this type of problem occurs only when you doesnot have jdk1.2
which includs javasoft runtime invironment
re-install your jdk and install jdk1.2
it will automatically install javasoft\runtime environment
if further problem persist
reply me
captain_sonil@yahoo.com
 
sunil seth
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hello ,HARSHAD bhawsar
your first problem was: http://localhost:1049/ the browser just hangs.
no need for doing that
after starting the server
open next command prompt
and set all the necessary path and classpath which you did in starting the server
then type
c:\j2sdkee1.2.1\bin>deploytool
this will automatically opens a window for deployment
then process your deployment
second problem:
you are getting the error like
Registry key 'Software\JavaSoft\Java Runtime Environment\CurrentVersion'
has value '1.1', but '1.2' is required.
this type of problem occurs only when you doesnot have jdk1.2
which includs javasoft runtime invironment
re-install your jdk and install jdk1.2
it will automatically install javasoft\runtime environment
if further problem persist
reply me
captain_sonil@yahoo.com
 
"Don't believe every tiny ad you see on the internet. But this one is rock solid." - George Washington
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic