Win a copy of Beginning Java 17 Fundamentals: Object-Oriented Programming in Java 17 this week in the Java in General forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Junilu Lacar
  • Rob Spoor
  • Paul Clapham
Saloon Keepers:
  • Tim Holloway
  • Tim Moores
  • Jesse Silverman
  • Stephan van Hulst
  • Carey Brown
  • Al Hobbs
  • Piet Souris
  • Frits Walraven

can't seem to get j2ee to start

Posts: 1
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I downloaded the j2ee yesterday got it all set up and
after reading every post there is at javaranch about
setting environment variable It still doesn't work.
1st problem:
I'm on a windows 98 michine.
I set all the variables in autoexec.bat.
I restarted my machine several time.
But each time I put j2ee -verbose it asks me to set
Even thought when I type set and hit enter I see
that j2ee_home is set.
When I type set j2ee_home from the command line it them works.
But even then I'm having some other problem.
when I type j2ee -verbose I'm getting
bad command or file error.
but when I type clouscape -start
it seems to almost work.
but I get this message and then it hangs:

Syntax error
Out of environment space
Sun Nov 04 17:56:32 HST 2001: [RmiJdbc] Starting Cloudscape RmiJdbc Server Versi
on 1.7.2 ...
Sun Nov 04 17:56:35 HST 2001: [RmiJdbc] COM.cloudscape.core.JDBCDriver registere
d in DriverManager
Sun Nov 04 17:56:35 HST 2001: [RmiJdbc] Binding RmiJdbcServer...
Sun Nov 04 17:56:35 HST 2001: [RmiJdbc] No installation of RMI Security Manager.
Sun Nov 04 17:56:35 HST 2001: [RmiJdbc] RmiJdbcServer bound in rmi registry

this is what i have in my autoexec.bat
------------------------------ C:\AUTOEXEC.BAT -------------------------------
PATH=%PATH%;"C:\Program Files\Mts";
SET JAVA_HOME=c:\j2sdk1.4.0-beta3;
SET J2EE_HOME=c:\j2sdkee1.3;
SET CLATHPATH=c:\java;c:\j2sdkee1.3\lib\j2ee.jar;

can you help me out.
all I wanted was to take a look at this j2ee and figure out what its all about. this little thing is hanging me up.
Ranch Hand
Posts: 71
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I doubt this is the answer because I am experiencing the same problem. But you did spell Classpath incorrectly (again I doubt that is it, but who knows).
Please let me know if you find the answer. It would help me out a great deal.
Ranch Hand
Posts: 224
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I just want to say I am able to work with J2EE RI (1.3) on Windows 98 machine without any problem. It took me nearly an hour to figure out what's going on. Finally I am able to start/stop/deploy and test my ejb applications.
Regarding the Out of Environment space, please visit the following FAQ from MicroSoft Out of Environment Space
If any body needs help on J2EE on Windows 98, please send me an e-mail.
Sreenivasa Kumar Majji
Sun Certified Java Programmer
SCJP Mock Test
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

I recently went through the same motions of installing and running the J2EE server. Starting the J2EE server from the script using the -verbose option also gave me the error:
bad command or file error
This may be due to the fact that there are 2 '=' in one of your script lines for the j2ee.bat file. Most likely the last line in the script where all the environment variables are glued together to run the application (ie j2ee server)
You may want to reference this June 4th post which explains why someone may get the bad command or file error and how to fix it. This was helpful in solving all of my command errors in both the J2EE and Runclient scripts.
Good Luck!
Posts: 12
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I am facing exactly the same problem running J2EE on Win98 ...
solved the following few problem after reading Noel's post :
1) Out of environment space is because the memory limit for the DOS window is less and cannot hold so many environment variables. This should be changed to another higher value (i made it 8192). refer
2) The other problem was because Win98 does not support the "=" while setting the environment variables. Thus it gives a syntax error when the setenv.bat file is run. This file is called by the j2ee.bat and the cloudscape.bat files. So unless this problem is solved - it gives either a syntax error or a Bad command as the proper variables are not set. refer to this comprehensive post from Noel
Now my problem ... the above method works to the extent that the bad command error is gone ... but unfortunately it gives an exception ... its an exception from Java ...
Problem 1
How do i find wht the exception is ... coz the window scrolls ... any clues as to how to get the information which has scrolled up...
Problem 2
Probably the exception is because i removed the %Listen_options% variable as suggested by Noel. Any idea what this problem is about ...
Thanks a lot in advance ...
in a rush to find out everything about this topic ...
WHAT is your favorite color? Blue, no yellow, ahhhhhhh! Tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
    Bookmark Topic Watch Topic
  • New Topic