• Post Reply Bookmark Topic Watch Topic
  • New Topic

org.omg.CORBA.NO_PERMISSION error, please help!

 
Not Available
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I got the following error message when I run a clientEJB
javax.naming.CommunicationException: org.omg.CORBA.NO_PERMISSION
does that mean role/security has not been properly set?
Thanks,
Cindy
 
Rich Raposa
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I got this error after I started using the final release of J2SDKEE1.3. If you deploy the client application to the server, then it fixes the problem.
To deploy the client, select "File" then "New... Application Client". Add the client's bytecode file, then deploy it to the server. There is a batch file in the j2sdkee1.3\bin folder called "runclient" that is used to run your deployed client app. You will be asked for a username (guest) and a password (guest123).
That should fix it. Let me know if you need more details.
Rich

Originally posted by Cindy Hu:
Hi,
I got the following error message when I run a clientEJB
javax.naming.CommunicationException: org.omg.CORBA.NO_PERMISSION
does that mean role/security has not been properly set?
Thanks,
Cindy

 
Marco Barenkamp
Ranch Hand
Posts: 94
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
select SECURITY tab and choose 'SUPPORT CLIENT CHOICE' in each EJB.
If you have no restictions set in your bean, the client will
run!
------------------
Marco Barenkamp
____________________________________________
L M I N T E R N E T S E R V I C E S AG
Senior Trainer & Architect,
BEA Certified Enterprise Developer
Sun Certified Programmer for the Java2 Platform
Sun Certified Web Component Developer for the Java2 Platform
Sun Certified Developer for the Java 2 Platform
Sun Certified Enterprise Architect for the Java 2 Platform Enterprise Edition (PI)
 
Not Available
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
My belated thank to Rich and Marco! After I deploy the application client and execute the "runclient", it worked!
I am running under Win98, so a few lines in runclient.bat
needs to be changed. Otherwise, the clientEJB is fine.
Cindy Hu
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!