Win a copy of Cross-Platform Desktop Applications: Using Node, Electron, and NW.js this week in the JavaScript forum!
    Bookmark Topic Watch Topic
  • New Topic

Deploy EJB from VisualCafe to Weblogic 5.1  RSS feed

 
A Harry
Ranch Hand
Posts: 124
  • Mark post as helpful
  • send pies
  • Report post to moderator
Sorry for cross postin in Weblogic group as well!
Anyway using VisualCafe 4.1 with Weblogic 5.1 (sp7) as supplied with Visual Cafe.
All I'm trying to do is prove that a EJB developed in VC can be deployed automatically in WL 5.1 using VC's "deploy" option
So I create a new EJB & add a single method "getName", build the app & select deploy. The help pages claim this option copies it to the EJB container, registers it & all the other convoluted stuff...
So in the messages window I get these really useful & meaninful error messages -
Internal VM (15:53:38): java.lang.NoClassDefFoundError: weblogic/ejbc
Internal VM (15:53:38): Exception in thread "main"
Internal VM (15:53:38): WebGain Java! JustInTime Compiler Version 4.00.007(x) for JDK 1.2
Internal VM (15:53:38): WebGain Java! JustInTime Compiler Version 4.00.007(x) for JDK 1.2
but I still end up with a .JAR file??? - albeit with a underscore as the first in its name
(what the hell does this mean?)
Why doesn't this work? - any ideas? - this really is doing my head in!
Thanks in advance.
 
Thomas Paul
mister krabs
Ranch Hand
Posts: 13974
  • Mark post as helpful
  • send pies
  • Report post to moderator
Cross posting is not permitted. Since this belongs in the WebLogic forum, I am closing it here.
 
    Bookmark Topic Watch Topic
  • New Topic
Boost this thread!