• Post Reply Bookmark Topic Watch Topic
  • New Topic

J2EE set up  RSS feed

 
s.r.k.reddy
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi friends,
I am old to java and new to J2EE, I am not able to run the j2ee server on my win98 despite setting the home and classpath in deploytool.bat and userconfig.bat
when i run the j2ee bat file it gives badcommand followed by outof environment space.
I am desperate to use this thing but my attempts are going in vain, if some on could help me out I will be thankful to them.
I have downloaded the j2sdkee1.3.1 from sun, and j2sdk. as well the copy of ant, but I am not able to set the environment.
Please Guide.
Rgds,
 
Sowmya BC
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
To fix the 'Out of environment space' problem you can do this:
- Right-click on the titlebar of the MS-DOS prompt window and select Properties.
- Select the memory tab and set all the values to maximum (Total Environment, Expanded (EMS) memory, Extended (XMS) memory, etc)
The classpath in deploytool.bat does not get set due to this problem. This gets resolved once the memory is set to maximum.
Hope this helps !!

Sowmya
 
s.r.k.reddy
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Souwmya,
It seem's that I forgot the basics using the Perl and PHP. But everything is not fine, when I enter j2ee on dos prompt and enter it says syntax error thrice and gives me the options for the j2ee like -verbose...etc, same is this with the deploytool..
I have set the path to the bin directories of j2sdkee1.3.1 and j2sdk
What might be the mistake? Any other pre-requisites.
Good Luck!.
 
Sowmya BC
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
If you have set
Path to c:\j2sdkee1.3.1\bin
Set J2EE_HOME=C:\j2sdkee1.3.1 &
Your installation is complete
- you should be able to start the deploytool/j2ee server from the command prompt.

Sowmya
 
s.r.k.reddy
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi sowmya,
Well it was the pblm of win98, I got some tips how to install on win98, the * symbol when removed was working well.
Now the pblm is the server is not running and deploytool and cloudscape are fine.
when I give J2EE -verbose it loads allclasses and terminates giving the options of usage? why is this happening?
if deploytool is running then obviously this should run isn't it.
Rgds,
 
Sowmya BC
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
>>if deploytool is running then obviously this should run isn't it.
If your server is not starting , the problem could be because of IP port conflicts.
You can check the log files under the installation directory to figure out what the problem is .

Sowmya
 
s.r.k.reddy
Greenhorn
Posts: 10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi
That was not the pblm sowmya,well I again re-installed the Edition and removed the * from the bat files and set the environment variables and path and it is working, I am really happy.
Thanks!
 
Consider Paul's rocket mass heater.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!