• Post Reply Bookmark Topic Watch Topic
  • New Topic

Starting pbm  RSS feed

 
Graham Thorpe
Ranch Hand
Posts: 265
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
HI everybody
Just now i got one surprise bug in my pc.
When i start weblogic7.0 server its running fine .When i type url in browser http://localhost:7001 i got exception like this

**********
Error 404--Not Found
From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:
10.4.5 404 Not Found
The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent.
If the server does not wish to make this information available to the client, the status code 403 (Forbidden) can be used instead. The 410 (Gone) status code SHOULD be used if the server knows, through some internally configurable mechanism, that an old resource is permanently unavailable and has no forwarding address.

************
But when i type http://localhost:7001/console its working fine ..So whats the problem in this server.
so any body know let me soon as possible
 
Dave Landers
Ranch Hand
Posts: 401
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I assume you are "looking for" one of your webapps? When you deploy a webapp, there is a context-root setting in web.xml that tells the server how you want to access it (what URL). If you package that webapp in an ear, then the ear can override context-root in its application.xml.
If you did not set context-root, then weblogic uses the name of the webapp (war or directroy) as the default. So if you deployed foo.war, then the url will be http://localhost:7001/foo/somepage.html
If you want the directory uri ("foo/") to map to some html or jsp file, then set the welcome-file in web.xml. If you set welcome-file to "index.jsp" then when your browser goes to ".../foo/", you will get .../foo/index.jsp.
If you want your webapp to be the "default" so it is served when you go to http://localhost:7001/, then set context-root to be just "/" and set welcome-file to the first file you want to serve.
Hope it helps - this stuff can get confusing.
 
Graham Thorpe
Ranch Hand
Posts: 265
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Mr.Dave i get it new thing from u .
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!