• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

new to j2ee1.4

 
Greenhorn
Posts: 22
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am an SCJP. I downloaded j2sdk1.4.1_01 as C:\j2sdk1.4.1_01 I downloaded j2sdkee1.4 as C:\j2sdkee1.4 . I set the path to include the bin directories from both the directories. I set Java_Home variable and J2EE_Home variable respectively. I do not have any classpath set.
I copied a CaseStudy application called CreateAgency source file, compiled file, and a Bat file from a CD Rom (that came with J2ee in 21 days book) Drive to the Coudscape subdirectory of j2ee.
The book instructs to run the application CreateAgency from the Cloudscape directory. When I do this I keep getting classdef not found error.
This happens whether I run the bat file or use java -classpath .;CreateAgency . Please help
 
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It is very important that you do one of two things:
1. set the CLASSPATH variable.
The CLASSPATH variable should be set to the following value based on the information in your post:
.;C:\j2sdk1.4.1_01\jre\lib\rt.jar;C:\j2sdk1.4.1_01\lib\tools.jar
How that variable is set depends on your particular OS.
Also, in addition to the value set above, there may be other additional values required by the project you are working with.
2. use the -classpath option with the java executable.
if, for some reason, you do not want to establish a global CLASSPATH environment variable, you can use the -classpath option as in the following example:
java -classpath .;C:\j2sdk1.4.1_01\jre\lib\rt.jar;C:\j2sdk1.4.1_01\lib\tools.jar <file name>
Note that I do not know the name of the file (jar, batch, or executable) so I used '<file name>' as a placeholder. Therefore, you must make the judgement call as to which technique to use.
Robert Troshynski
P.S. - in reviewing my own particular setup, I have noted that I am using J2SDKEE 1.3.1. If I remember right, I was using 1.4, but backed off to 1.3.1 due to a problem that may have been a missing class file. Soooo, you might try a previous version of J2SDKEE.
[ January 07, 2003: Message edited by: Robert Troshynski ]
 
Heroic work plunger man. Please allow me to introduce you to this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
    Bookmark Topic Watch Topic
  • New Topic