• Post Reply Bookmark Topic Watch Topic
  • New Topic

Unable to run deploytool  RSS feed

 
Eric Tinney
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I got error when running "deploytool -ui" :
No local string for enterprise.tools.deployment.main.error_creating_ui
Unable to create UI: java.lang.ClassNotFoundException: com.sun.enterprise.tools.deployment.ui.DT
I'm using J2SDK 1.4 and J2EE 1.3.1 running on Win98. I can run cloudscape and j2ee without problem.
Has anyone experienced this problem ?
Regards,
 
Simon Brown
sharp shooter, and author
Ranch Hand
Posts: 1913
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I usually just run "deploytool".
Simon
 
Eric Tinney
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When I run "deploytool", I got :
Starting Deployment tool, version 1.3.1
(Type 'deploytool -help' for command line options)
No local string for enterprise.tools.deployment.main.error_creating_ui
Unable to create UI: java.lang.ClassNotFoundException: com.sun.enterprise.tools.deployment.ui.DT
That's why I have to run "deploytool -ui", though option -ui is the default.
Any idea of the problem ?
Regards,
 
Robert Troshynski
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Check out the following thread:
http://www.coderanch.com/t/310962/EJB-JEE/java/Problems-getting-started
Robert Troshynski
 
Eric Tinney
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have tried many versions of those batch files (setenv, j2ee, deploytool), but it still doesn't work for me. I still got the same error in runnign deploytool.
Do I miss anything in classpath ?
With an error of : No local string for enterprise.tools.deployment.main.error_creating_ui
I can fix by edit file %J2EE_HOME%\lib\locale\com\sun\enterprise\tools\deployment\main\localStrings, and put the line
"enterprises.tools.deployment.main.error_creating_ui=Any Message Here" inside.
But an error still in :
Unable to create UI: java.lang.ClassNotFoundException: com.sun.enterprise.tools.deployment.ui.DT
Where is the jar file which has "com.sun.enterprise.tools.deployment.ui.DT" ?
I would like to try to specify it in my classpath.
Any idea of this problem, please.
Regards,
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!