• Post Reply Bookmark Topic Watch Topic
  • New Topic

RMI andJRE 1.3.1 upgrade throws SecurityException: Prohibited Package  RSS feed

 
Dean Walker
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello all,
I've recently updgraded my JRE from 1.2.2 to 1.3.1. A server application that receives RMI requests from clients now throws the following exception
java.lang.SecurityException: Prohibited package name: java.net
This was not a problem with JRE 1.2.2. It looks like the server application is trying to access classes in java.net on the client.
Can anybody help with this?
thanks,
Dean
 
Lasse Koskela
author
Sheriff
Posts: 11962
5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Tweak the .policy file on the client (wherever it may be, don't ask me).
 
Consider Paul's rocket mass heater.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!