• Post Reply Bookmark Topic Watch Topic
  • New Topic

stuck with errors, please help !!

 
Lee Dow
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have created an j2ee application using jBuilder X and jBoss 3.2.2. It was working wonderful in a PC
but now I am trying to run it in another different PC and it goes crazy (both PCs have the same OS (XP)).
I am a beginner with EJB and jBuilder so I maybe doing (or not doing) something I cannot see as an error.
Please help, I am totally stuck!

Here goes the story:

Sometimes when in jBuilder I do ctrl+F9 and next the application deployment, in jBoss server\default\deploy
appears next to the *-ds.xml a copy of the .ear .war and .jar which I think it did not happened in the original PC where the aplication was created.


Some other times after doing the ctrl+F9, jBuilder shows this error:

ERROR [MainDeployer] Could not initialise deloyment: file:/C:/jboss-3.2.2/server/default/conf/jboss-service.xml

org.jboss.deployment.DeploymentException:
Document root element is missing.; - nested throwable:
(org.xml.sax.SAXParseException: Document root element is missing.)

at org.jboss.deployment.SARDeployer.init(SARDeployer.java:151)



If the ctrl+F9 & deployment goes fine I run jBoss, here the error parade:

javax.management.InstanceAlreadyExistsException: jboss.j2ee:jndiName=Products/MyBeanRemote,service=EJB
already registered.

javax.management.InstanceAlreadyExistsException: jboss.management.local:J2EEApplication=ejb,
J2EEServer=Local,j2eeType=EJBModule,name=MyBean.jar already registered.

Could not create JSR-77 EJBModule: MyBean.jar
javax.management.InstanceAlreadyExistsException: jboss.management.local:J2EEApplication=ejb,
J2EEServer=Local,j2eeType=EJBModule,name=MyBean.jar already registered.

ERROR [org.jboss.deployment.MainDeployer] could not start deployment:
file:/C:/ejb/Products/ProductsApplication/MyWebModule.war
org.jboss.deployment.DeploymentException: Error during deploy; - nested throwable:
(java.lang.IllegalArgumentException: addChild: Child name '/MyWebModule' is not unique)



There are no other folders in C:/ejb/
In server/default/conf/jboss-service.xml I have just added:

<attribute name="URLs">
deploy/,
file:/C:/ejb
</attribute>

Any idea of what is going wrong? at least of what should I check???

Many thanks in advance
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!