Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

java beans and java 1.1.8  RSS feed

 
ju doyle
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I'm running Jeode (java 1.1.8) on a PDA on top of which I've placed Swing libraries. I'm trying to run an application which depends on JavaBeans but keep getting the error:
'java.lang.noClassDefFoundError: java/beans/beancontext/BeanContextChild'

I've no problem running the app under java 1.4.1. Is there something I need to do to get JavaBeans working with 1.1.8?

Thanks alot.
 
Paul Sturrock
Bartender
Posts: 10336
Eclipse IDE Hibernate Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
According to the JavaDocs, that class has only existed since 1.2. So the "thing" you will have to get is newer JRE.

Also something worth explaining: JavaBeans and Enterprise Java Beans are two different and distinct things.
[ February 07, 2005: Message edited by: Paul Sturrock ]
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!